Android Question 4.0 is doing Animated Activities

Robert Valentino

Well-Known Member
Licensed User
I just upgrade 4.0 and now when I do a StartActivity(aReuse) ' aReuse is a Activity

You can see the Activity start and the window animated opens from left to right

What caused this to start happening - never saw this in the 3.xx versions

And I only see it in this Activity - I call others and not of them seem to do this

How can I fix this and by fix I mean turn it off - better question is what turned it on?


After more testing I can see ALL the windows are opening Animated but this is the only one open with a Left to Right Expanding Animation the rest are just exploding (I guess from the center) Why would this one be doing Left to Right?


More testing. EVERY Activity Window I touch or change in Designer (just opening a window in designer causes the Animation Duration to be added causes a change). Once saved it starts opening from Left to Right

BobVal
 
Last edited:

Robert Valentino

Well-Known Member
Licensed User
Thanks that kind of helps.

it does say:
3. Layout animations. Layouts created with the designer are optionally animated. The animation is based on the views anchors:
Sure seems like this option should be off by default when converting an existing screen
 

Robert Valentino

Well-Known Member
Licensed User
Well after setting all the Animation Durations to 0 everything looks like it did before.

Nice feature, but I think it would have been nicer if Designer put zero in the Animation Duration so as not to change the appear of an already running App.

Just my feeling - I thought I had done something seriously wrong

BobVal
 

AllyAndroid

Member
Licensed User
Well after setting all the Animation Durations to 0 everything looks like it did before.

Nice feature, but I think it would have been nicer if Designer put zero in the Animation Duration so as not to change the appear of an already running App.

Just my feeling - I thought I had done something seriously wrong

BobVal
I agree with you. I've been trying to figure out what was going on. I knew about the animations but not that they were already set to 400. I had some of my own animations set up. I thought maybe they were not working right.
 

Robert Valentino

Well-Known Member
Licensed User
Great at least I am not the only one that thought his code was working weird.

Turning 64 last weekend and installing the new software Monday - I couldn't understand what I had done differently (other then Brain Fart)

I am trying to figure out how to make the screen animate where it opens from the center out.

Starts small in the middle and expands outward from all sides.
 

bluedude

Well-Known Member
Licensed User
Not sure I get this, I can animate the Activity from left to right by having one view with right anchor?
 

Erel

Administrator
Staff member
Licensed User
Sorry must have missed that.
You didn't miss it. It didn't appear in the beta notes.

ot sure I get this, I can animate the Activity from left to right by having one view with right anchor?
The designer layout animation animates the layout when it is loaded. The activity itself is not animated.

The layout direction of each view is based on the anchors.
 

b2mvga

Member
Licensed User
After I download new version (4.0) of B4A I have crash problems in my app without any modifications...I only recompile it...

I have one app with a button that open a layoute and after click on a list in this layoute the app return to previous layoute with some info... Sometimes when I execute "LOADLAYOUT" the app crash (message ANDROID STOPPED... WAIT, OK)

I use on my screens:

AutoScaleRate(0.8)
AutoScaleAll

I see in new version when open new layoute, now have something like “animation” opening from top left to bottom right (in previous version this not exist)

Have any change on AutoscaleRate/AutoScaleAll ?

After upgrade I have many problems with my customers after only re-compile my app with new version... today I uninstall B4A 4.0 and reinstall B4A 3.8 and recompile app... at moment, no crash anymore
 

b2mvga

Member
Licensed User
The error appears in my customers smartphones... I will try reproduce error and get the logs...

The app freeze and msg WAIT, OK appears... if click WAIT the app continue freeze... if click OK app close...

I Compile same app with previous version (3.8) and at moment my customer say me not error anymore... the only diference I see is the "animation" when I load a new layout on my activity...
 

specci48

Well-Known Member
Licensed User
For some reasons I did not update B4A to version 4.00 until yesterday.
Now, after i did, my "converted" existing screens are animated.
To prevent this unwanted behavior I have to set the animation duration to 0, but how do I do this, or what is the best way to do this?
 

lemonisdead

Well-Known Member
Licensed User
To prevent this unwanted behavior I have to set the animation duration to 0, but how do I do this, or what is the best way to do this?
Hello,
You have to open your layouts with the Designer, click on "Activity" and put 0 into the "Animation duration (ms)" field
 

specci48

Well-Known Member
Licensed User
Hello,
You have to open your layouts with the Designer, click on "Activity" and put 0 into the "Animation duration (ms)" field
Got it, thanks.
I was confused because I thought I have to set it individually for each view so I didn't look to the activity properties... :-(
 
Top