Android Question 4.4 kitkat no longer work applications using the magnetic sensor !!!

Spectre

Active Member
Licensed User
Longtime User
HI!
I updated the phone to Android 4.4 does not work for me most applications using the magnetic sensor !. Only those written in other B4...
other downloaded from the Market (GPS Status, SmartTools) work ... Possible bug?
 

lemonisdead

Well-Known Member
Licensed User
Longtime User
Hi,
Hope this could help : I already had such issue while using initialize2 (nothing returned by the sensor). Solved by initializing with the initialize only.
 
Upvote 0

ptp170

Member
Licensed User
Longtime User
I'm getting this too. All of my apps that use Magnetics 'fail' on KitKat. Am using B4A 3.8.

I am working on debugging my easiest app first to try and suss out what's going on. My initial search points to weird readings from the Sub Sensor_SensorChanged (Values() As Float) although I could be wrong. I will update this thread as I discover more :)
 
Upvote 0

ptp170

Member
Licensed User
Longtime User
Ignoring my own Apps for a minute. I've retried the Sensor Example project on my new phone running 4.4.3.
The magnetics sensor reports back, X=0,Y=0,Z=-1,541,952,432,780,780,000,000 regardless of actual real changes in magnetic strength.

This is the same issue that appears to be tripping up my own app.

EDIT: I am using Phone v2.25 if this makes any difference..
 
Last edited:
Upvote 0

ptp170

Member
Licensed User
Longtime User
Can you post a screenshot of your device running the sensors example?
And just for clarity, all the other readings update fine, it's just the Magnetics values that are frozen with those values you see on the screenshot.

Let me know if you require any more information :)
 

Attachments

  • Screenshot_2014-10-02-08-41-19.png
    Screenshot_2014-10-02-08-41-19.png
    123.2 KB · Views: 206
Last edited:
Upvote 0

James Chamblin

Active Member
Licensed User
Longtime User
I wonder if this has anything to do with the bug I had on my phone? The compass would always point exactly 90 degrees from where I was facing, no matter how many times I calibrated it. Using 4.3, but maybe a software fix was broken when upgrading to 4.4? My problem was fixed using this method.

I would add one step to the link above, Step 2.5) if the keyboard pops up, press back to dismiss it.
 
Upvote 0
Top