Android Question aapt.exe still an issue?

Discussion in 'Android Questions' started by goffretus, Jul 4, 2015.

  1. goffretus

    goffretus Member Licensed User

    I have not been able to get an understandable answer to this issue.

    b4a v 2.52
    attempting compile of html5wrapper
    fails with error -
    Cannot find: C:\Program Files\Android\Android Studio\plugins\tools\..\platform-tools\aapt.exe

    Current installer puts it here:
    C:\Program Files\Android\android-sdk\build-tools\22.0.1\aapt.exe

    Tried moving and configuring path to :
    C:\Program Files\Android\Android Studio\plugins\tools\22.0.1\platform-tools\aapt.exe

    NOT OK

    Not sure where it should be!

    Help anyone?
     
  2. NJDude

    NJDude Expert Licensed User

    Just reinstall the Android SDK.
     
    lemonisdead likes this.
  3. goffretus

    goffretus Member Licensed User

    Thanks but that did not fix it. Uninstalled and re-installed the sdk with all packages
    windows 7 ultimate
    g
     
  4. sorex

    sorex Expert Licensed User

    copy the file in your search path like c:\windows maybe it will find it then
     
  5. Erel

    Erel Administrator Staff Member Licensed User

    Make sure to update the path after you install the SDK (Tools - Configure Paths).
     
  6. goffretus

    goffretus Member Licensed User

    Thanks for suggestions I set system
    Path=C:\Program Files\Android\android-sdk\build-tools\
    then
    Tried each of following in |tools | configure path
    C:\Program Files\Android\android-sdk\build-tools\19.1.0
    C:\Program Files\Android\android-sdk\build-tools\20.0.0
    C:\Program Files\Android\android-sdk\build-tools\21.1.2
    C:\Program Files\Android\android-sdk\build-tools\22.0.1
    regretably without success
    g
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    You don't need to edit the ini file.

    I recommend you to close the IDE and delete the ini file.

    Now open the IDE and configure the paths.
     
  8. goffretus

    goffretus Member Licensed User

    the ini file contains other setting so I removed the android path entry and tried all versions again with the same result.
    I have 64bit win 8.1 available that I could try with but I do not know how to move B4A
    g
     
  9. Erel

    Erel Administrator Staff Member Licensed User

    I still recommend you to delete the ini file, install the latest Android SDK and reconfigure it.
     
  10. goffretus

    goffretus Member Licensed User

    Hi Erel,
    b4a v2.52
    win 7 ultimate 32 bit
    I removed the only ini file under C:\program files\anywhere software\
    I unistalled and re-installed android studio complete with sdk

    I adjusted tools |configure path for additional library to:-
    C:\Users\<user>\AppData\Local\Android\sdk1\build-tools\22.0.1\
    other paths unchanged

    no change to error message on compiling with B4A

    regards
    g
     
  11. DonManfred

    DonManfred Expert Licensed User

    The ini file is in your app-data folder

    On MY PC it is:
    C:\Users\ManfredSsykor\AppData\Roaming\Anywhere Software\Basic4android\b4xV5.ini
     
  12. Erel

    Erel Administrator Staff Member Licensed User

    I'm sorry I missed the fact that you are using v2.52. This is an old version. It probably doesn't support the latest structure of Android SDK.

    You will need to find aapt.exe and copy it to the path you see in the IDE error message.
     
    DonManfred likes this.
  13. goffretus

    goffretus Member Licensed User

    Thank you but the path is incomplete -
    C:\Program Files\Android\Android Studio\plugins\tools\..\platform-tools\aapt.exe
     
  14. Erel

    Erel Administrator Staff Member Licensed User

    It is complete. .. = parent folder

    So the path is:
    C:\Program Files\Android\Android Studio\plugins\platform-tools\aapt.exe
     
  15. goffretus

    goffretus Member Licensed User

    Thank you, that seems resolved but new error is -
    Generating R file. Error
    ERROR: Asset package include 'C:\Program Files\Android\Android Studio\plugins\android\lib\android.jar' not found.

    And yet that is the correct location and configure paths | browse button finds it exactly there.
    g
     
  16. DonManfred

    DonManfred Expert Licensed User

    Hmmm... Sounds for me that you have defined the wrong path to the android.jar

    [​IMG]

    In my case the UPPER one is the rigth one. The path inside the android studio is not the same file....
     
  17. goffretus

    goffretus Member Licensed User

    thanks to Manfred Erel and all who assisted

    good paths for old B4A with new android studio v22

    C:\Users\<user>\AppData\Local\Android\sdk1\platforms\android-22\android.jar
    C:\Users\<user>\AppData\Local\Android\sdk1\platform-tools\aapt.exe
    C:\Users\<user>\AppData\Local\Android\sdk1\tools\zipalign.exe

    g
     
    Erel likes this.
  18. rtesluk

    rtesluk Member Licensed User

    Mar 14 2016
    My experience with Android SDK is that if there is problem with the emulations I think it's a VERSION problem with an app within the SDK, so I reinstall the SDK but I check EVERYTHING so that the various apps within, upgrade in a sequential fashion.
    The other thing you can do (I have done this) is to take copy of appt.exe from a previous upgrade and just paste it in the current upgrade overwriting the current appt.exe. It has worked for me when I am too lazy to reinstall the whole SDK.
     
  19. Awesome Student 123

    Awesome Student 123 Member Licensed User

    I tried everything but I still get the error
    ERROR: Asset package include 'C:\Program Files\Android\android-studio\plugins\android\lib\android.jar' not found.
    Help
     
  20. DonManfred

    DonManfred Expert Licensed User

    1. ALWAYS create a new thread for any new problem! Your issue is NOT related to THIS thread. Create your own.
    2. Dont use the android ja installed with android studio. Use the Android jar from the SDK-Installation.
     
    lemonisdead likes this.
Loading...