B4J Question and another ClassCastException [SOLVED]

Discussion in 'B4J Questions' started by koffie, Mar 10, 2015.

  1. koffie

    koffie Member Licensed User

    My b4j program works great. It decrypts incoming AES/CBC/PKCS5Padding data through asyncprefix.

    But every time after around 740-750 loops it says

    java.lang.ClassCastException: java.lang.StackOverflowError cannot be cast to java.lang.Exception

    so 740-750 times no probs....and then it does not decrypt the data anymore.
    I tested the incoming data. It is not corrupted in any way.

    When I physically restart the app...everything goes until it reaches approx. 740 loops.

    Any hints ?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    The real error is probably the stack overflow. Can you post the full logs?
     
  3. koffie

    koffie Member Licensed User

    I am not able to reproduce the error in debug, but I did find a 'startmessageloop'...hidden in a place outside MAIN.:oops::oops: could that be the problem ?
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    It depends. There are valid usages of StartMessageLoop outside of the main method.
     
  5. koffie

    koffie Member Licensed User

    After 24 hours and more then a thousand decryptions...everything looks okay. I think it was the (overlooked) :rolleyes::rolleyes: Startmessageloop that caused the stackoverflow...

    Thanks
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice