Android Question Android Emulator - AVD Menager Error:

ilan

Expert
Licensed User
hi

i am trying to run the emulator on b4a v9.8 and i am getting an error:

error1.png


any idea what could be the problem? it worked fine on b4a v9.3

thanx, ilan
 

ilan

Expert
Licensed User
Do you get this error when you try to create a new AVD?

No error.

Try to delete <sdk>\B4AEmulator and C:\Users\<user name>\.android

i tried everything for the last 3 hours :(
deleting, reinstall sdk, reinstall b4a and all needed file like in a new pc but nothing helps.
when i try on android studio it also does not work anymore.

after googling a little bit i tried to add system environment variables but still it doesnot work.
on android i get this error now:

00:49 Emulator: PANIC: Broken AVD system path. Check your ANDROID_SDK_ROOT value [C:\Android\sdk]!

before adding the environment variables i had this error on Android studio:

00:55 Emulator: PANIC: Cannot find AVD system path. Please define ANDROID_SDK_ROOT

my android path is: C:\Android\sdk
my avd path is: C:\Users\אילן\.android\avd

maybe the hebrew letters are the problem?
 
Upvote 0

ilan

Expert
Licensed User
ok, so after changing the environment variables and setting a new avd folder to c:\avd i can now start the emulator on Android Studio.

avd.png


but on b4a i still get an error. i guess that b4a still tries to run it from the old folder (C:\Users\אילן\.android\avd )

i think the Hebrew letters are the problem so can i set somewhere in b4a that the avd folder is now on c:\avd ?

thanx
 
Upvote 0

ilan

Expert
Licensed User
If you can start the emulator from Android Studio then start it like this.

ok, thanks. thats what i will do :)
 
Upvote 0
Top