Android Question Attribute "layout_anchorGravity" already defined with incompatible format

superkan

Member
Licensed User
Hi,

I am using Firebase storage (FirebaseStorage 1.11+ FirebaseAuth 1.04) example as a starting point and added TabStripViewPager (v1.10). These two (Firebase and TabStripViewPager) are not working with each other simultaneously but work when individually used - I have posted the error log. I am not so familiar with maven and dependency. What I tried was, changed the android-support version in TabStripViewPager xml file from v4 to v6 but it then asked me where the android-support-v6.jar was in the libraries folder. So that didn't work and I changed it back to v4. Guided from a SO answer, I also tried to delete the 'already defined' attributes in the log from the respective values.xml files (keeping the 'Original attribute' ones intact ) but then it resulted in a 'top level' error which stropped the translation and I reverted back all corrections from my side.


error log during compile:
B4A Version: 8.30
Parsing code.    (0.01s)
Compiling code.    (0.04s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (2.20s)
Generating R file.    Error
D:\FirebaseStorageKB\Objects\bin\extra\res3\res\values\values.xml:28: error: Attribute "layout_anchorGravity" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res8\res\values\values.xml:30: Original attribute defined here.
D:\FirebaseStorageKB\Objects\bin\extra\res3\res\values\values.xml:67: error: Attribute "layout_insetEdge" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res8\res\values\values.xml:67: Original attribute defined here.
D:\FirebaseStorageKB\Objects\bin\extra\res3\res\values\values.xml:84: error: Attribute "layout_dodgeInsetEdges" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res8\res\values\values.xml:86: Original attribute defined here.
D:\FirebaseStorageKB\Objects\bin\extra\res2\res\values\values.xml:36: error: Attribute "fontProviderFetchStrategy" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res6\res\values\values.xml:42: Original attribute defined here.
D:\FirebaseStorageKB\Objects\bin\extra\res2\res\values\values.xml:51: error: Attribute "fontProviderFetchTimeout" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res6\res\values\values.xml:54: Original attribute defined here.
D:\FirebaseStorageKB\Objects\bin\extra\res2\res\values\values.xml:61: error: Attribute "fontStyle" already defined with incompatible format.
D:\FirebaseStorageKB\Objects\bin\extra\res6\res\values\values.xml:62: Original attribute defined here.



My Manifest looks like:
manifest:
'This code will be applied to the manifest file during compilation.
'You do not need to modify it in most cases.
'See this link for for more information: https://www.b4x.com/forum/showthread.php?p=78136
AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="28"/>
<supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
'End of default text.

CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)
CreateResourceFromFile(Macro, FirebaseAnalytics.Firebase)
CreateResourceFromFile(Macro, FirebaseAuth.FirebaseAuth)

AddApplicationText(
<service android:name="com.google.firebase.components.ComponentDiscoveryService" >
            <meta-data
                android:name="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar"
                android:value="com.google.firebase.components.ComponentRegistrar" />
             <meta-data
                android:name="com.google.firebase.components:com.google.firebase.iid.Registrar"
                android:value="com.google.firebase.components.ComponentRegistrar" />
             <meta-data
                android:name="com.google.firebase.components:com.google.firebase.auth.FirebaseAuthRegistrar"
                android:value="com.google.firebase.components.ComponentRegistrar" />
            <meta-data
                android:name="com.google.firebase.components:com.google.firebase.storage.StorageRegistrar"
                android:value="com.google.firebase.components.ComponentRegistrar" />
        </service>
)
 
Last edited:

DonManfred

Expert
Licensed User
B4A Version: 8.30 Parsing code. (0.01s) Compiling code. (0.04s) Compiling layouts code. (0.00s) Organizing libraries. (2.20s) Generating R file. Error
The newest Firebase artifacts depends on AndroidX

Guess you need an B4A Update and switch to AndroidX. You need B4A 9.3+ i think.

 
Upvote 0
Top