Android Question B4A 12.20 and WebViewExtras

luke2012

Well-Known Member
Licensed User
Longtime User
Hi everyone. I have updated to the latest version of B4A, 12.20, and first of all congratulations to @Erel for the important updates that this version contains.

I opened a project created with a version of B4A from about 2 years ago, and when I open it, the IDE gives me the error: "Unknown type WebViewExtras - Are you missing a library reference ?"

In the new version of B4A, has this library somehow been decommissioned or excluded?
 

agraham

Expert
Licensed User
Longtime User
WebViewExtras is not an official library so is not installed with B4A. It is also about 12 years old now.

 
Upvote 0

JohnC

Expert
Licensed User
Longtime User
WebViewExtras is not an official library so is not installed with B4A. It is also about 12 years old now.
It's a excellent library - I use it in every project that has a webview in it :)
 
Last edited:
Upvote 0

drgottjr

Well-Known Member
Licensed User
Longtime User
i think op's webviewextras library has gone missing. it was always meant to go in the additional libraries folder, not in b4a's main libraries folder. if that is where op had webviewextras, and if he deleted the anywheresoftware folder before installing version 12.2, he deleted webviewextras. he may need to download it again and put it in the additional libraries folder, where it belongs (technically, nothing's stopping him from putting it in b4a's main folder, but he'll only have the same problem the next time he deletes that folder). if the library actually is already in the additional libraries folder, then it is possible he needs to select it in the ide's libraries tab. i, along with many others - some of whom have already valiantly stepped forward - use it regularly.
 
Last edited:
Upvote 0

luke2012

Well-Known Member
Licensed User
Longtime User
Hello and first of all thanks for your advice.

I can confirm that the ipath of the folder for additional libraries hasn't changed (as a setting within the IDE), so for some reason (which I still don't understand) the library file has been deleted.

In fact, the quickest way to fix the problem is to download the library file again (it's another matter to figure out why it's gone).

P.S.
SOLVED downloading WebViewExtras

P.S. 2
Using 12.20, it it mandatory to also change the api level ? Actually I'm using: C:\Android\platforms\android-30\android.jar
 
Last edited:
Upvote 0

GMan

Well-Known Member
Licensed User
Longtime User
Its always good to be up to date...with everything šŸ¤˜
 
Upvote 0
Top