Other B4A 9.01.2 Installing file to device. Error [Resolved see post 34]

Status
Not open for further replies.

itgirl

Active Member
Licensed User
After updating to V 9.01.2 I get a weird error [Installing file to device. Error] even though the app is installed on the device but the problem is with the Debug mode it gives the same message but the debug process does not work ??!! any one encountered this issue too ?

I disabled my Antivirus also tried to run B4A as administrator none worked ??

B4A Version: 9.01.2
Java Version: 11
 

aidymp

Well-Known Member
Licensed User
I'm able to reproduce it. It is related to an update to the build tools.
The latest version of adb.exe returns wrong error codes.

I'm able to get it working by copying adb.exe from <sdk>\platform-tools.backup to <sdk>\platform-tools.

I dont have the .backup folder. I just downloaded the first version I could see online!
Which came to this page ADB Kits downloading and extracting the ADB Kits.zip file into <sdk>\platform-tools. It happened to be 2.0.0 where the installed one was 2.0.1 All working now thanks!!
 
Last edited:
Upvote 0

itgirl

Active Member
Licensed User
I don't have it either, and I have the same problem with the emulator.
Could you clarify how you reinstalled it?
Thank you!
There is a folder <sdk>\platform-tools.backup if you dont have this folder i think you can get the adb versions and download it online
 
Upvote 0

rabbitBUSH

Well-Known Member
Licensed User
Yeah it's funny how our beloved B4A can't have bugs but the bugs comes from Google lol , anyways i changed the title in order to help any other who are facing this issue to resolve it faster. again thanks Erel
JA Ditto
I actually found that the adb.exe file had disappeared from the /platform-tools folder (must have been during the SDK updating) found the copy and replaced now it all works. I posted separately about this but don't know yet how to cross-reference that posting here.....
 
Upvote 0
Status
Not open for further replies.
Top