Android Question B4A Logging No Longer Working

Stealth Pyro

Member
Licensed User
I'm not sure why, but my logging stopped working. I've always used B4A Bridge with my phone on Wi-Fi and was able to work fine with B4A's log pane, but all of a sudden it is not working. I have reinstalled B4A (even used an older version that I'm positive I was using fine previously, which had fixed the duplicate log output bug on 4.1+), switched Android ROMs, Recovery to no avail. B4A's log view does say:

LogCat connected to: B4A-Bridge: samsung GT-I9505G-##### (numbers that I'm assuming are my Device's ID)

Any help is appreciated...
 

Stealth Pyro

Member
Licensed User
Do you get a "cannot open dev main"?
No not at all

Use the latest version of B4A-Bridge. There isn't any better version.

Are you running your app in debug mode?
I am in debug mode. I just installed the latest version again after switching ROMs once more and it seems to be working. Now I'm having an issue with Google Play Services. Odd since I used the same ROM I was initially on when logging wasn't working

My app is crashing when starting one of my activities with a message telling me that my manifest file must have the following declaration within the <application> element: <meta-data android:name="com.google.android.gms.version" android:value="@Integer/google_play_services_version" /> However I do have this. Troubleshooting as I post this. Update: solved by re-copying the Google Play Services jar (I updated and forgot to update the jar into the libraries folder).
 
Last edited:
Top