Android Question B4A SSL Handshake Error

Discussion in 'Android Questions' started by bitben, Sep 18, 2018.

  1. bitben

    bitben Member Licensed User

    Hello,
    yes i know there are many threads about this, but i have found no solution to my - i think - special problem.

    I need to connect to this url: https://ssfbln.dyndns.org:444/mb/index.asp
    There is no need to install an sec. certificate, i can load it and login in chrome without certificate.

    Code is simple:
    Code:
    Dim check as HttpJob
    check.Initialize(
    "start", Me)
    check.Download(
    "https://ssfbln.dyndns.org:444/mb/index.asp")
    later i added:
    Code:
    check.GetRequest.SetHeader("Accept","text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8")
    check.GetRequest.SetContentEncoding(
    "gzip, deflate, br")
    check.GetRequest.SetHeader(
    "Acept-Language","de,en-US;q=0.7,en;q=0.3")
    check.GetRequest.SetHeader(
    "User-Agent","Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0")
    From my mobile phone i get an ssl handshake error, but from windows emulator BlueStacks or Andy are no errors, all works fine there like it should.
    I tried it with HttpUtils2Service and changed
    to
    but nothing, same in webview, it is blank, but when i load https://www.google.com with both methods it worked.

    Same with WebSocket, not working, both give error connection closed by peer, but with google worked.

    Are there some changes i have to do in phone settings or somewhere else?

    Please help
     
  2. KMatle

    KMatle Expert Licensed User

    Even Chrome shows "not safe". It's better to fix that Website.
     
  3. MarkusR

    MarkusR Well-Known Member Licensed User

    firefox said this
     
  4. bitben

    bitben Member Licensed User

    I know these things, i talked to an Admin and he said they will fix whole login system and maybe then it should work.. i have to wait for that. Thanks for help
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice