Bug? B4A v.5.02 IDE on XP SP3 is very slow during typing on the keyboard.

Discussion in 'Bugs & wishlist' started by PierPaduan, Jun 18, 2015.

  1. PierPaduan

    PierPaduan Member Licensed User

    Hi,
    B4A v.5.02 IDE on XP SP3 is very slow during typing on the keyboard.
    The pressed letter appears on screen about one second after or more. The IDE is almost unusable.
    With v.4.30 the IDE was very fast.
    In addition during typing, today, the IDE crashed two times in less than half an hour.

    The Information about the crash are the following:
    EventType : clr20r3 P1 : b4a.exe P2 : 5.0.0.0 P3 : 557d94a4
    P4 : mscorlib P5 : 4.0.0.0 P6 : 4ba1da6f P7 : 219 P8 : 10
    P9 : system.invalidoperationexception

    I have tried disabling implicit auto completion, but nothing changed.

    Can I reinstall v.4.30 ?

    Do you have some suggestions?

    Thanks a Lot
     
    Last edited: Jun 18, 2015
  2. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Are you running itunes by any chance ?
     
  3. Informatix

    Informatix Expert Licensed User

    Yes, uninstall v5 and reinstall V4.30. It's what I did.
     
    lemonisdead and cimperia like this.
  4. sorex

    sorex Expert Licensed User

    @PierPaduan : turn off the explicit autocomplete and it should be a lot faster (Tools -> IDE -> disable explict autocompletion)
     
  5. sorex

    sorex Expert Licensed User

    oh, you tried that already. check taskmanager to see if something is eating too much resources.
     
  6. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Try booting up in safe mode and see whats happens
     
  7. PierPaduan

    PierPaduan Member Licensed User

    No itunes
    There isn't.

    I think my old computer is too old.
    Without autocompletion it's a little faster, but not very much. But I need autocompletion.
    Other problem are the crashes, that happens only when I change values in a big array... strange!!!

    Anyway, for the moment I will downgrade to 4.3.

    Thanks a Lot to everybody.
    Bye.
     
  8. sorex

    sorex Expert Licensed User

    I don't know if it is Erel's own implementation or something that's built-in in VS201x but I guess it's the delay between keystrokes that's set too small or doesn't get reset at keypresses.

    As mentioned before other IDE's that have simular autocompletion options don't have this issue on my machines.
     
  9. francoisg

    francoisg Active Member Licensed User

    I can second the delay - I am using a vm on mac and the new ide is really slow compared to the previous version. turned off auto complete. will check if it makes it usable ...
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    On most computers the new IDE will be faster (on large projects especially).

    If you can try to upgrade the VM to Windows 7+ and .Net 4.5.2.
     
  11. francoisg

    francoisg Active Member Licensed User

    Hi,
    I am on using Windows 8 VM (VirtualBox) on the MAC and it definitely is slower! I turned off auto complete but it is still the same :-(
     
  12. Erel

    Erel Administrator Staff Member Licensed User

  13. francoisg

    francoisg Active Member Licensed User

    Hi, tried turning on 2d/3d acceleration (using virtualbox) but now it even feels slower! Up to the point of being unusable! Any ideas?
     
  14. Erel

    Erel Administrator Staff Member Licensed User

    I've tested the IDE on several Windows XP computers and the performance was good. I guess that the problem is related to the virtual machine in some way.
    Currently I don't have any other solution to offer you.
     
  15. german13

    german13 Member Licensed User


    The problem is vmware.
    Disable 3D acceleration and it works great and fast.
     

    Attached Files:

  16. francoisg

    francoisg Active Member Licensed User

    Actually, it's not - I am using Windows 8 on VIRTUALBOX (not vmware) - and I have spoken to someone else with the same problem. Only he is on a Windows 8.1 laptop ...
     
  17. german13

    german13 Member Licensed User

    I think the problem is related directly with the DirectX driver
     
  18. francoisg

    francoisg Active Member Licensed User

    I have no clue but I'm up to the point of reinstalling the older version and sticking with it for a while ...
     
  19. LuanKotze

    LuanKotze Member Licensed User

    In an effort to be of help, I can also second the delay on my under powered (Mecer NetTop Atom 430N) running Win7 x64, .net 4.5.2. I also tried a fresh XP Virtual Machine on my 3rd gen i5 laptop, cannot test on host OS due to some .net issues, any-case same delay. Disabling 3d acceleration on the vm did remove most of the delay and the v5 IDE is very usable. Both run the v4.xx IDE very smoothly. Unfortunately re-opening my project on an earlier IDE produces a warning, and I don't want any additional issues. I will be formatting an older i5 (1st gen m520) Toshiba laptop and installing a fresh Win 7 sometime this week, will report back my findings here.
     
    Last edited: Jul 27, 2015
  20. sorex

    sorex Expert Licensed User

    I have the issue aswell on non-virtual windows systems so I don't think it's always related to VMware/VBox. That's on XP & 7 so with different .NET & DX configs.

    in my case turning of the autocomplete helps altho it's still not as smooth as all other IDE's I use or used before.

    My guess, as mentioned back then, is it's the pre-compile check that gives warnings of errors on every keypress
    or the lack of timer reset during keypresses for the autocomplete to kick in.
     
Loading...