iOS Question b4i bridge and different computers

sorex

Expert
Licensed User
Hello,

I finally managed to get B4i working on my desktop and I'm able to compile and send the program to the phone.

Out of curiosity on the flexibility of the keys & certificates I installed B4i on this netbook aswell.

After a few tweaks it all seems to work right but at the moment that it is supposed to send to the phone nothing happends.

UNLESS

I redo the "build B4i bridge app" again and install it again on the phone.

BUT

now it doesn't send anymore from the desktop to the phone.

Is the machine hostname or something added to the bridge apk so that not every machine can install apps to the pointed IP device?

This makes thing kind of complicated since I change machines a lot depending of where I'm working in the house.
 

Erel

Administrator
Staff member
Licensed User
Is the machine hostname or something added to the bridge apk so that not every machine can install apps to the pointed IP device?
No. The gateway IP of the current local network is stored inside B4i-Bridge. This later helps with making the connection faster.

In most cases you can use the same B4i-Bridge with different computers. If you do encounter a problem then you can create another B4i-Bridge. Just change the package name and it will create a new one instead of overwriting the existing one.
 

sorex

Expert
Licensed User
the gateway is the same as I'm on the same lan.

I will give that double bridge option a try but how do I quit the running "faulty" bridge.
Out of habbit I always keep pressing where the back key is on Android phones but that doesn't do much :)

It would also be nice if the bridge app showed the IP on that empty page ;)
 

sorex

Expert
Licensed User
I gave it another try which first seemed to work but then it didn't anymore.

1. compile on laptop > ok
2. compile on desktop > ok
3. compile on laptop > keeps waiting to send app
4. close app & bridge on phone (thanks for the closing hint)
5. compile on laptop again > ok, now it asks to install the app again

seems something got stuck somewhere inbetween which prevents installs.
 

sorex

Expert
Licensed User
oh, it stays connected even after the package has been sent and even closed?

that explains a lot, so I should just close the ide on the other machine.
 
Top