iOS Question B4i Bridge won't install

luke2012

Well-Known Member
Licensed User
Hi all,
I'm trying to install B4i bridge on an iPhone 5s (iOS 12.5) but without success.

I used the @Erel official tutorial (https://www.b4x.com/android/forum/t...bridge-and-debugging-first-app.45871/#content) and I did all steps:
1) Installed the B4I certificate (and it's enabled on the device) ---> OK
2) Set the package name based on the provision app id ---> OK
3) Build B4i-Bridge: Tools -> Build Server -> Build B4i-Bridge (Compilation was successful and I also got the QRCode) ---> OK
4) Open mobile Safari and navigate to the link displayed in the compilation window (I'm able to open it using QRCode) ---> OK
So all the above steps are OK and no errors.

5) Install B4i-Bridge and run it ---> KO
When I "click" on the round button "Install App" (Latest B4i-Bridge build) nothing happens: the button was pushed (without errors) but when I go to the app list the B4i-Bridge isn't present.
I repeat the setup process 2 / 3 times but nothing to do :-(

I'm using B4i-6.80 (local build server).
Any idea to solve this problem ?

Thanks for your help.
Luca.
 

aeric

Expert
Licensed User
Do you also go to device Settings > General > About, scroll to bottom and look for Certificate Trust Settings then enable B4I ?
 
Upvote 0

aeric

Expert
Licensed User
Do you have Apple Developer account then add your device UDID to the provisional profile?
 
Upvote 0

Alex_197

Active Member
Licensed User
Apple Test Flight and App Store Connect are went down for more than 24 hours. Maybe it's not related but I'd like to let you know
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
just in case it helps:
1) Make sure you added your device on Apple
2) remove/delete (Certificate, Provision) and start again.
3) I sometimes use developer Certificate and provision to install B4i bridge.
4) Make sure you are following the steps just like in the video, order: certificate then provision (not sure about it, but I follow that order)
5) because you are using " local build server" probably you will need help from an expert here :)
 
Upvote 0

luke2012

Well-Known Member
Licensed User
First step is to try with the hosted builder.
I've sent you a temporary id. Try it.

Thanks @Erel! It's solved!
I installed the B4i-Bridge using hosted builder and I install and debug a B4i App successfully.
Then I switch to my local builder and now the apps installation and debug works correctly.

So when I have a B4i license expired and I renew it, as first step I have to use a temporary user on hosted builder and than I can switch to my local builder ?
 
Upvote 0
Top