B4J Question [B4JServer] Could not locate b4xV5.ini … [ERROR]: missing the html files.

LJG

Member
Please note that I am new to B4J. I have made progress but I am stuck in a frustrating place right now. Any help would be much appreciated. Here is the issue:

1. I am working in a Windows 10/VirtualBox (Ubuntu Server) environment.
2. I am compiling my Win 10 B4J BANanoServer WebSocket PWA based project with the "Recommended: OpenJDK 11 + OpenJFX 11"
3. On the Ubuntu Server, I copied over the Linux version of OpenJDK 11 + OpenJFX 11 (linux_jdk-11.0.1)
4. I am logged into the Ubuntu Server with full sudo rights, all required ports are open, and full rights are on for all files/folders involved in this test/learning project.
5. On the Ubuntu Server side, I have the project jar in my /home directory and the HTML in the /home/www directory.
6. The only files and folder that I moved into the Ubuntu Server are the jar file, the server.ini file, and, of course, the www folder and its contents (please see the attached image of my Win10 B4J project folder - do I need to move any other files or folders (besides the ones I mentioned) over to the Ubuntu Server side?).
7. I start the Ubuntu Server jar with this line: sudo home/java_linux_1101/bin/java -jar home/PWA_ServerClient2.jar (I use line instead of the nohup one because I can immediately see the results in the console for testing).
8. After I start it, I can see a "Resource Not Found" message in the web browser, and the web browser console shows that the browser does hit the server but with "GET http://192.168.1.101:55055/home 404 (Not Found)" and "Navigated to http://192.168.1.101:55055/home".
9. This is what I get on the Ubuntu Server-side (please note that I did include the www folder and the HTML files as noted above):

Port: 55055
SSL Port: 0
Reading B4J INI in / to find Additional Libraries folder...
Could not locate b4xV5.ini! [ERROR]: missing the html files. You will have to use Initialize2 and set the full path to the Additional Libraries folder yourself.
[ERROR]: missing the html files. Did you copy the www folder?
2020-11-07 17:54:09.262:INFO::main: Logging initialized @551ms to org.eclipse.jetty.util.log.StdErrLog
2020-11-07 17:54:09.508:INFO:eek:ejs.Server:main: jetty-9.4.z-SNAPSHOT; built: 2018-05-03T15:56:21.710Z; git: daa59876e6f384329b122929e70a80934569428c; jvm 11.0.1+13
2020-11-07 17:54:09.565:INFO:eek:ejs.session:main: DefaultSessionIdManager workerName=node0
2020-11-07 17:54:09.566:INFO:eek:ejs.session:main: No SessionScavenger set, using defaults
2020-11-07 17:54:09.569:INFO:eek:ejs.session:main: node0 Scavenging every 600000ms
2020-11-07 17:54:09.609:INFO:eek:ejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@2362f559{/,file:///www/,AVAILABLE}
2020-11-07 17:54:09.614:INFO:eek:ejs.AbstractNCSARequestLog:main: Opened /logs/b4j-2020_11_07.request.log
2020-11-07 17:54:09.646:INFO:eek:ejs.AbstractConnector:main: Started ServerConnector@5570d67d{HTTP/1.1,[http/1.1]}{0.0.0.0:55055}
2020-11-07 17:54:09.649:INFO:eek:ejs.Server:main: Started @946ms
2020-11-07 17:54:09.673:INFO:eek:ejs.AbstractConnector:main: Stopped ServerConnector@5570d67d{HTTP/1.1,[http/1.1]}{0.0.0.0:55055}
2020-11-07 17:54:09.677:INFO:eek:ejs.session:main: node0 Stopped scavenging
2020-11-07 17:54:09.681:INFO:eek:ejsh.ContextHandler:main: Stopped o.e.j.s.ServletContextHandler@2362f559{/,file:///www/,UNAVAILABLE}
2020-11-07 17:54:09.691:INFO:eek:ejs.Server:main: jetty-9.4.z-SNAPSHOT; built: 2018-05-03T15:56:21.710Z; git: daa59876e6f384329b122929e70a80934569428c; jvm 11.0.1+13
2020-11-07 17:54:09.696:INFO:eek:ejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@2362f559{/,file:///www/,AVAILABLE}
2020-11-07 17:54:09.699:INFO:eek:ejs.AbstractNCSARequestLog:main: Opened /logs/b4j-2020_11_07.request.log
2020-11-07 17:54:09.700:INFO:eek:ejs.session:main: DefaultSessionIdManager workerName=node0
2020-11-07 17:54:09.700:INFO:eek:ejs.session:main: No SessionScavenger set, using defaults
2020-11-07 17:54:09.701:INFO:eek:ejs.session:main: node0 Scavenging every 660000ms
2020-11-07 17:54:09.705:INFO:eek:ejs.AbstractConnector:main: Started ServerConnector@5570d67d{HTTP/1.1,[http/1.1]}{0.0.0.0:55055}
2020-11-07 17:54:09.707:INFO:eek:ejs.Server:main: Started @1005ms
2020-11-07 17:54:09.708:INFO:eek:ejs.session:main: node0 Scavenging every 33000ms
Scavenger running... (0 page(s) cached)

Please help if you can (thanks).
 

Attachments

  • screenshot.jpg
    screenshot.jpg
    62.3 KB · Views: 47
Top