Bug? [Beta v5.0] bugs ..

Discussion in 'Bugs & wishlist' started by ilan, May 31, 2015.

  1. ilan

    ilan Expert Licensed User

    I have tried beta v5.0 and I found some bugs on projects that runs well on v4.82

    1) wrong End Sub error msg:

    i get an error says End Sub is missing but as you can see in the picture it is not missing...

    error1.png

    2) Canvas drawing:

    when I want to draw a circle or line normally after "canvas.drawline(" I should get a info popup that tells me what parameter I should enter but in beta v5.0 I don't get it like in older versions.

    WISH:

    in the designer please add a possibility to move the window in the abstract designer right/left top/down maybe by press and hold the SPACE button (or maybe hold the middle mouse button and move in the abstract designer) its really frustrating to move right and left via taskbars.

    for now I downgrade to version 4.82 for me its simpler and runs faster...

    regards, ilan
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Can you upload the service module that causes this error?
     
  3. ilan

    ilan Expert Licensed User

    Yes, will do it after work
     
    Peter Simpson likes this.
  4. ilan

    ilan Expert Licensed User

    as promissed i send you the service file

    Good Luck ;)
     

    Attached Files:

  5. Peter Simpson

    Peter Simpson Expert Licensed User

    Hello @ilan,
    You have a sub called stop_Click. The problem is at the end of the sub where you would usually have End Sub, you actually have End Sub', you have added an apostrophe (') to the end of the End Sub line 127. Just remove the apostrophe at the end of line 127 and everything will work perfectly fine.
     
  6. ilan

    ilan Expert Licensed User

    The apostrophe (') in the end of the line should not effect the code, if i want to write a note in the line End_Sub '... that should be possible like in older versions so this is in my opinion a bug that should be fixed. i put lot of notes in my code and i guess other too so this should work as it worked on older versions...
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    It is fixed for the next update.
     
    ilan likes this.
  8. qsrtech

    qsrtech Active Member Licensed User

    4.82? Did i miss some upgrades cause i'm pretty sure i'm only at 4.3?
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice