iOS Question Bridge wont install

ilan

Expert
Licensed User
Longtime User
i am not able to install the Bridge app on my iPhone 11 ios15.0.2

i am using b4i 7.5 and it does not matter what i do the bridge won't install.
i have updated certificate + provisions files.


if i uncheck Use Apple Configuration to install i get this.
(B4i-Bridge could not been installed, try again later)

1.png


4.png




if i use Apple configuration to install i get this:

(The Developer of the App needs to update the App to be able to run it on this IOS Version)

3.png



Please HELP!!!!! :(
 

ilan

Expert
Licensed User
Longtime User
1) Forget about a bridge.
2) Connect a smartphone using USB cable.
3) Install AC2 on MAC and check "Use Apple Configuration" flag
4) Check 64-bit flag

this is not working. i dont think it is possible without having the bridge app installed.

i get an error:

B4i Version: 7.50
Parsing code. (0.12s)
Building folders structure. (0.01s)
Running custom action. (0.03s)
Compiling code. (0.25s)
Compiling layouts code. (0.01s)
Compiling debugger engine code. (1.73s)
Building Xcode project. (0.10s)
Preparing project for builder. (0.17s)
Project size: 0.76 MB
Sending data to remote compiler. Error
Error: No devices are booted.

Error: No devices are booted.


besides that i wont be able to see the layout without the bridge app.
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
Try to install it via AirDrop

sending it through airdrop doesnot do much. i cannot install it like this. it just send the file but nothing happens if i open it.
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
Ok, if you want to see layout, you need Bridge-app.
I don't see problems with it installation.

B4X:
B4i Version: 7.80
Parsing code.    (0.00s)
Building folders structure.    (0.02s)
Compiling code.    (0.00s)
Building designer app.    (0.01s)
Building Xcode project.    (0.17s)
Preparing project for builder.    (0.04s)
    Project size: 0.23 MB
Sending data to remote compiler.    (17.73s)
    App installed successfully using Apple Configurator.
Completed successfully.
Manually launch the app after installation.

I used latest releases (Monterey, XCode 13.1, IOS 15.1, B4i 7.80. But the same was in previous releases.
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
Ok, if you want to see layout, you need Bridge-app.
I don't see problems with it installation.

B4X:
B4i Version: 7.80
Parsing code.    (0.00s)
Building folders structure.    (0.02s)
Compiling code.    (0.00s)
Building designer app.    (0.01s)
Building Xcode project.    (0.17s)
Preparing project for builder.    (0.04s)
    Project size: 0.23 MB
Sending data to remote compiler.    (17.73s)
    App installed successfully using Apple Configurator.
Completed successfully.
Manually launch the app after installation.

I used latest releases (Monterey, XCode 13.1, IOS 15.1, B4i 7.80. But the same was in previous releases.

i have xcode 12.0.1 i cannot install newer version because i run Catalina.
could that be the problem?
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
XCode 12.0.1 exactly does not support IOS 15. Why Catalina ?

when b4i was announced i ran to the store and bought me a new macmini. it was in middle 2013 i think and the model i have is mac mini (Late 2012). i dont get any updates anymore 😭😭😭

does it mean i have now to buy a new mac?
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
Use VM (for example, VMWare for Windows). it's necessary to make a patch (which is easy to find in Internet). Not too fast like native devices. but enough good.
 
Upvote 0
D

Deleted member 103

Guest
sending it through airdrop doesnot do much. i cannot install it like this. it just send the file but nothing happens if i open it.
I exactly the same problem, then I tried so much that I no longer know how I solved the problem.
But my Mac-mini is from 2014 and it still gets all the updates.
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
Longtime User
when b4i was announced i ran to the store and bought me a new macmini. it was in middle 2013 i think and the model i have is mac mini (Late 2012). i dont get any updates anymore 😭😭😭

does it mean i have now to buy a new mac?
Off of the topic - just want to say I got my Mac in 2014 (or around the same time Erel created the Hosted solution, don't remember) never never used my Mac 😅 always using the Hosted Builder (Windows) easy 😉
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
Off of the topic - just want to say I got my Mac in 2014 (or around the same time Erel created the Hosted solution, don't remember) never never used my Mac 😅 always using the Hosted Builder (Windows) easy 😉
this is probably what i will do but working with the local builder is faster and i can use the simulator. actually i still can use it i just cannot install the app to my phone
i guess i will buy the hosted builder since it is cheaper then buying a new mac.
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
Try to update to the latest Xcode 12 version.
ok i will try. now i am running xcode v12.0.1 but i saw that i can update to v12.4

i will update and see if it solve the issue. thanks erel
 
Upvote 0

ilan

Expert
Licensed User
Longtime User
the latest Xcode v12.4 is only for later OS versions so i cannot update Xcode to v12.4. the latest update i have is v12.0.1 which is the version i am running.
so i guess i will need the hosted builder or a new mac.
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
Longtime User
@ilan
Check this: (from a reddit's user)
"Ctrl click xcode/show package contents/ contents/ developer/platforms/iphoneos.platform/devicesupport. Copy the folder of the os you've been using then paste it and rename it 14.5.

It worked for me running a couple things on my apple TVs when they updated to 14.5. I run xcode on a 2010 macbook that has patched catalina. But I can't update to big sur because it isn't..."

 
Upvote 0
Top