B4J Question Cannot Login: Lesson 3 - MySQL and CRUD / ABMTables

boontong

Member
Dear Experts,
Sorry for my Dummies question again. My web background is not very solid, I am just try to move from windows app to web app with my vb6, ms access and ms sql background. I am now trying Lesson 3 - MySQL and CRUD / ABMTables. I have Wamp64 setup and running on my local machine. I follow Harris' instruction ( #AdditionalJar: mysql-connector-java-5.1.44-bin, Public UsingDB As Boolean = True, create my sql database with phpadmin, create database "bounthong" and insert data with users.sql, made change in main appstart: DBM.InitializeMySQL("jdbc:mysql://localhost/bounthong?characterEncoding=utf8", "Admin", "admin", 100 ), I start to run http://localhost:51045/template/HomePage/ on Edge web browser, it seems showing properly, I try to login with User demo and password demo, then it fails. I attach screenshots of debug screens of my b4j here,
please help to advise what I am doing wrong, and what area I should learn more to catch up with this technology.

Thank and advance,
bounthong
 

Attachments

  • Screenshot1.png
    Screenshot1.png
    220.1 KB · Views: 40
  • Screenshot2.png
    Screenshot2.png
    111.1 KB · Views: 39
  • Screenshot3.png
    Screenshot3.png
    98.4 KB · Views: 34
  • Screenshot4.png
    Screenshot4.png
    168.6 KB · Views: 34
  • Screenshot5.png
    Screenshot5.png
    118.9 KB · Views: 33
  • Screenshot6.png
    Screenshot6.png
    115.9 KB · Views: 38
  • Screenshot7.png
    Screenshot7.png
    120.6 KB · Views: 37

MichalK73

Active Member
Licensed User
Longtime User
As soon as I looked.
I suspect that the database works with SSL and you are trying to connect without SSL.
Run the database without SSL and check.

A light note.
Put the code in the CODE tag in the post editor, not as text. This is a bad read.
Copy the log code from the B4J log window and paste it as text, not as pictures.
 
Upvote 0

Harris

Expert
Licensed User
Longtime User
Note the use of &useSSL=false in the code below, during the init of MySQL...
(explicitly set) as the error log complains of...

B4X:
    DBM.InitializeMySQL("jdbc:mysql://localhost/municipal?characterEncoding=utf8&useSSL=false", "Admin", "admin", 50)     ' s1 server
 
Upvote 0

boontong

Member
Thank you Michal and Harris,
I have changed the code for the initialization of DBM as Harris advised, and also added user Admin with password admin in for MySQL database, now I can login, if any questions I may be back for your help again.
Thanks for your help and your great job and tools you have done.
 
Last edited:
Upvote 0
Top