Android Question Cannot open adb.log [Solved]


New Member
Hello All,
First time user with B4A, Working through the first tutorial, two random numbers, enter result. I get the following error:

B4A Version: 10.0
Java Version: 11
Parsing code. (0.11s)
Building folders structure. (0.31s)
Running custom action. (0.33s)
Compiling code. (0.13s)
Compiling layouts code. (0.01s)
Organizing libraries. (0.00s)
(AndroidX SDK)
Generating R file. (0.00s)
Compiling debugger engine code. (20.62s)
Compiling generated Java code. (18.02s)
Convert byte code - optimized dex. (8.09s)
Packaging files. (1.03s)
Copying libraries resources (0.00s)
Signing package file (debug key). (3.51s)
ZipAlign file. (0.17s)
Installing file to device. Error
* daemon not running; starting now at tcp:5037
adb F 09-11 10:31:53 3916 9808 main.cpp:49] cannot open C:\Users\Robert\AppData\Local\Temp\adb.log: Permission denied
could not read ok from ADB Server
* failed to start daemon
adb.exe: failed to check server version: cannot connect to daemon

I searched post, and found one solved by running as administrator, I am.
I tried changing permissions on ...\Temp folder to read/write.

Where is the path set for the adb.log file? Can I change it?


New Member

Found a file:
Already existing, and did not pay close attention to the date stamp of 04/12/2019, I installed B4A on 09/10/2020. Must have been left over from an attempt to program Android last year, with a different program.
Deleted that old adb.log file, and BAM! now I can install the tutorial programs, and now the WYSIWYG works also finally.

B4A does not trap the error "adb.log file already exists, overwrite? Y/N?"

OK, back to the tutorials, after 2 days of struggle on that....
Upvote 0