Cannot type in Device IDE

Discussion in 'Bug Reports' started by Leginus, Feb 2, 2008.

  1. Leginus

    Leginus Member Licensed User

    I am now on version 60 of my code, which for the last two days I have been editing on my desktop. I came to edit this tonight in the pda and I cannot type anything into the device. I tried version 59 of my code and that was the same, so I have reverted to 58 and added the new code back in and this is fine.

    The bad versions run ok on the device and you can edit them fine on the desktop and compile them, it is just that you cant type anything (including enter or backspace) into the device IDE. I find that I spend more time coding on the Device than I do the desktop so this is a little inconvenient :sign0013:

    Is this a known bug and is there an easy way around this?

    ps. I have noticed this before but my code was tiny then ::)
    My version is 6.05
    thanks
     
  2. Leginus

    Leginus Member Licensed User

    Just as a quick update and certainly a lesson learned for me :sign0060:

    Rather than editing it all manually like last time, I have just tried the FormDuplicator tool and it fixed it.

    I decided to compare the 2 versions in Notepad which indicentally I have never done before. There seemed to be a lot of erroneous characters in the bad file like little squares. I am assuming this will be extra chr(13) or chr(10) but i havent looked to check it fully.

    anyway thought I would let you all know. Its fixed and formduplicator is a good tool
     
  3. derez

    derez Expert Licensed User

    typing in the device

    the problem is probably that you exceeded the maximum size (I think 64k) that the the device can handle.
    if this is the case you have two options:
    1. work on the desktop and transfer it to the device, for every editing you need.
    2. Split your code to two files, the second one save as text file and call it from "components". Of course, to edit this file you need a text editor (pword or similar).
     
  4. Leginus

    Leginus Member Licensed User

    Ah thanks. I didnt realise there was a maximum size, so this will probably be the next hurdle. Thanks for the solution :sign0060:
     
Loading...