iOS Question Can't create private sign key

Chris Guanzon

Active Member
Licensed User
Hello everyone, I can't create a private sign key, I can successfully connected to my local mac device.

1599196624673.png


I also read this, but it doesn't have enough information on how to fix my problem. What is the correct user id i need to use? i just add a test name for this. thanks
 

Chris Guanzon

Active Member
Licensed User
It doesn't matter with the local builder.

What do you see in the server logs?

this is in the server logs:

B4X:
2020-09-04 16:25:27.684:WARN:eek:ejh.HttpParser:qtp517380410-95: Illegal character 0x16 in state=START for buffer HeapByteBuffer@1a1c75dd[p=1,l=147,c=8192,r=146]={\x16<<<\x03\x03\x00\x8e\x01\x00\x00\x8a\x03\x03_Q\xF9\xF8^yi...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>36 (KHTML, like G...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}

2020-09-04 16:25:27.692:WARN:eek:ejh.HttpParser:qtp517380410-83: Illegal character 0x16 in state=START for buffer HeapByteBuffer@1a1c75dd[p=1,l=147,c=8192,r=146]={\x16<<<\x03\x03\x00\x8e\x01\x00\x00\x8a\x03\x03_Q\xF9\xF8m/C...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>36 (KHTML, like G...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}

Are you able to run an app on the simulator?

I am still in the process of creating a certificate and provisioning.
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
Can be a lot of reasons. Maybe B4iBuildServer is not running on MAC (you closed terminal window or reboot and did not run again)
Or incorrect settings in Tools - Build Server - Server settings. For example, wrong Server IP. I see 192.168.1.16. Did you fix this address in router or in MAC network settings ? Etc.
 
Upvote 0

Chris Guanzon

Active Member
Licensed User
Can be a lot of reasons. Maybe B4iBuildServer is not running on MAC (you closed terminal window or reboot and did not run again)
Or incorrect settings in Tools - Build Server - Server settings. For example, wrong Server IP. I see 192.168.1.16. Did you fix this address in router or in MAC network settings ? Etc.

I can connect to my local mac machine, see in Post #1, that means the buildserver is running and my settings is correct and i also turned the firewall off in my mac, I also uninstall and reinstall the IDE but same error. What do i need to do with my router? In the tutorial of @Erel it is easy to connect to the local mac and it doesn't need any configuration in router as long as you can connect and test it.
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
Did you terminate terminal window and restart B4iBuidServer ? B4iBuildServer does not work after attempt to use 51041.

BTW, why exactly 51042. Because 51041 is http.
When you start B4iBuildServer, it writes at the bottom
Build server is ready
https://<MAC IP>:51042
http://<MAC IP>:51041
Build server version: 6.80
 
Upvote 0

Chris Guanzon

Active Member
Licensed User
Did you terminate terminal window and restart B4iBuidServer ? B4iBuildServer does not work after attempt to use 51041.

BTW, why exactly 51042. Because 51041 is http.
When you start B4iBuildServer, it writes at the bottom

the first time i run the buildserver i used the http, then tried the https and i have the same error. i searched the forum and i found 1(see post #1), but it doesn't have enough information on how to fix it. before i ask a question here i already tried any possible reasons, but no luck.

I also tried to install the 6.50 version, same error. Am i the only one now having this problem? 😅
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
Last edited:
Upvote 0

Chris Guanzon

Active Member
Licensed User
https://www.b4x.com/android/forum/threads/cant-create-keystore-file.89742/ looks like another story. Your error message does not include Error retrieving token
Guess, just now you are really alone, who has this problem :)
What do you see in terminal window on MAC ? On myPC I see one line only - CSR: true.

'Fresh' topic -- https://www.b4x.com/android/forum/threads/keystore-file.121951/#post-762144 Hope, it's not your case and B4iBuildServer is correct.

I downloaded the buildserver again from my email and replace the one i am using. I thought it's gonna work, but i received same error. This is the logs in my server logs.

B4X:
2020-09-05 08:24:41.288:WARN:eek:ejh.HttpParser:qtp517380410-32: Illegal character 0x16 in state=START for buffer HeapByteBuffer@2dbafd3c[p=1,l=147,c=8192,r=146]={\x16<<<\x03\x03\x00\x8e\x01\x00\x00\x8a\x03\x03_R\xDa\xC9m\xDf1...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>36 (KHTML, like G...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}


2020-09-05 08:24:41.293:WARN:eek:ejh.HttpParser:qtp517380410-43: Illegal character 0x16 in state=START for buffer HeapByteBuffer@2dbafd3c[p=1,l=147,c=8192,r=146]={\x16<<<\x03\x03\x00\x8e\x01\x00\x00\x8a\x03\x03_R\xDa\xC9\x9f\xDb[...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>36 (KHTML, like G...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
I saw similar output when port was 51041.
B4X:
2020-09-05 03:34:29.790:WARN:eek:ejh.HttpParser:qtp653305407-36: Illegal character 0x16 in state=START for buffer HeapByteBuffer@2c6f3265[p=1,l=185,c=8192,r=184]={\x16<<<\x03\x03\x00\xB4\x01\x00\x00\xB0\x03\x03_R\xDd\x16\xE8\x9b\xA1...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}
2020-09-05 03:34:29.818:WARN:eek:ejh.HttpParser:qtp653305407-39: Illegal character 0x16 in state=START for buffer HeapByteBuffer@2c6f3265[p=1,l=153,c=8192,r=152]={\x16<<<\x03\x03\x00\x94\x01\x00\x00\x90\x03\x03_R\xDd\x16\xDfR\xBf...\x06\x03\x00#\x00\x00\x00\x17\x00\x00\xFf\x01\x00\x01\x00>>>\x06\x04\x01\x05\x01\x02\x01\x04\x03\x05\x03\x02\x03\x02\x02\x06\x01...\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00}
But after switching to port 51042, even without restarting B4iBuildServer, I got "CSR: true"
 
Last edited:
Upvote 0
Top