Android Question Can't hide Webview Zoom Controls when using IME

Discussion in 'Android Questions' started by JohnC, May 16, 2018.

  1. JohnC

    JohnC Well-Known Member Licensed User

    I am displaying a remote webpage using webview and I am using IME to resize the webview control when the keyboard gets displayed/hidden so any text boxes will be visible when the user is typing text into a webpage.

    However, the zoom controls of the webview appear every time the user just scrolls the screen - even if they don't do a pinch/zoom gesture.

    I tried doing this:
    Code:
    wv.ZoomEnabled = False
    And that didn't work

    I tried to hide the zoom controls using the lib (https://www.b4x.com/android/forum/threads/webviewsettings.12929/) and that didn't work.

    I narrowed the problem down to this line:
    Code:
    IME.AddHeightChangedEvent
    If I remove this line, then the Zoom controls wont appear using either of the above methods.

    Is there a conflict between the webview and IME?
     
    Last edited: May 16, 2018
  2. Erel

    Erel Administrator Staff Member Licensed User

    Can you upload a small project that demonstrates this issue?
     
  3. JohnC

    JohnC Well-Known Member Licensed User

    I found the problem.

    If you have "ZoomEnabled" checked for the webview control in the "designer" then this will happen (you wont be able to hide zoom controls when using IME.HeightChanged).

    When I unchecked it, then the zoom controls stayed hidden
     
    peacemaker likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice