iOS Question Code Sign error: No codesigning identities found

David Cochrane

Member
Licensed User
Longtime User
I have created and downloaded from Apple developer center necessary certificate files to Keys folder but when I try to build bridge app for hosted builder (ID= ac***a5), got this error

=========
B4i version: 2.31
Parsing code. (0.00s)
Compiling code. (0.02s)
Building designer app. (0.01s)
Building Xcode project (0.02s)
Sending data to remote compiler. Error
Out: Build settings from command line:
ARCHS = armv7
CODE_SIGN_IDENTITY = iPhone
CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PRODUCT_NAME = B4i-Bridge
PROVISIONING_PROFILE = 5dad7f94-6d48-4a94-bc3e-5f1e94dbc87b

=== BUILD TARGET B4iProject OF PROJECT B4iProject WITH CONFIGURATION Release ===

Check dependencies
Code Sign error: No codesigning identities found: No codesigning identities (i.e. certificate and private key pairs) that match the provisioning profile specified in your build settings (“CP iOS Provisioning Profile”) were found.


Error: ** BUILD FAILED **


The following build commands failed:
Check dependencies
(1 failure)
===========

Is this a problem on your side and hosted builder does not recognize my credentials or I have to change something in my B4i IDE?
 

David Cochrane

Member
Licensed User
Longtime User
Based on the error the certificate and provision profile do not match. Try to delete all keys and recreate them.

I have deleted and re-created both certificate and provision profile and again get the same error
=======
Code Sign error: No codesigning identities found: No codesigning identities (i.e. certificate and private key pairs) that match the provisioning profile specified in your build settings (“3Y34Z9BSMP.com.patterns”) were found.
=======
How they may mismatch if only a single certificate exists in my Apple profile and generated provision profile file based on that certificate?
What I'm doing wrong?
What is a "private key" mentioned in the error message? How to make that match to certificate?
As far as I know during certificate generation Apple doesn't care about B4i settings.

In my B4i Build Configuration set to "com.patterns" and I cannot set it to "com.patterns.*" as I did in Apple center.
What password I have to use in Private Sign Key?
Where to get that or it is arbitrary?
 

Attachments

  • profile4.gif
    profile4.gif
    6.3 KB · Views: 342
  • profile4b.gif
    profile4b.gif
    9.8 KB · Views: 322
Upvote 0

David Cochrane

Member
Licensed User
Longtime User
I have removed all password files, certificates and provision files to start from scratch.

1) Have generated in B4i a private sign key to create a certificate request file "certSigningRequest.csr". OK
2) Tried to request from Apple website by using Fire Fox browser a certificate. Got an error
==========
Invalid CSR
Select a valid Certificate Signing Request.
============
3) Repeated step 2 with Safari for Windows. Got an error:
===========
File Error
Your browser does not support FileReader API.
===========

Must say, that certificate request files generated in OS X (El Capitan) work fine with any browser, including the above ones.

Also I tried to get a certificate in OS X Safari browser by using a request file generated by B4i in Windows but got the same "Invalid CSR" error.
============
I have created CSR file with SSL command lines as you recommended in
https://www.b4x.com/android/forum/threads/invalid-csr.64288/#post-407155
and now browser accepted the file but finished with this
===========
AJAX ERROR
421
==========
 
Last edited:
Upvote 0

David Cochrane

Member
Licensed User
Longtime User
Finally, I've got Bridge Builder created and started but still unable to run a startup example app.
There is a prompt on iPad:

63.135.179.51 would like to install "B4i Example"
Cancel Install

When I tap Install, B4i Example installs but when I launch that, it displays

"IP address 192.168.0.102"
Waiting for IDE to connect...

and falls into endless waiting. I don't see a normally started example with "Page 1" title
 
Upvote 0

David Cochrane

Member
Licensed User
Longtime User
Bridge starts but freezes with the message
===================
"IP address 192.168.0.102"
Waiting for IDE to connect..
===================

Designer displays in status bar:

WYSIWYG status: Trying to connect. Make sure that B4i-Bridge is started (192.168.0.102)
 
Upvote 0

David Cochrane

Member
Licensed User
Longtime User
Erel, thank you for your help.
I've moved from my old Windows 7 installation to new fresh bare Windows 10 setup and everything works fine.
 
Upvote 0
Top