iOS Question Compiler timing out can't test anymore

chuck3e

Active Member
Licensed User
I'm using the hosted builder. At approximately 1pm USA Central Time my compiles started timing out. I was at B4i version 7.0 and thought maybe I needed an upgrade to fix it but 7.20 is timing out also. I tried to rebuild the Bridge app but it timed out too. I'm not getting any other error except the one below.

B4i Version: 7.20
Parsing code. (0.13s)
Building folders structure. (0.21s)
Running custom action. (0.04s)
Compiling code. (0.39s)
Compiling layouts code. (0.04s)
Building Xcode project. (0.39s)
Preparing project for builder. (0.35s)
Project size: 1.54 MB
Sending data to remote compiler. Error
Communication error: Timeout
 

MikeSW17

Active Member
Licensed User
It doesn't say the Compilation is Timing-out. It says COMMUNICATION with the device is timing-out.
How is your device connected to your development machine (WiFI/USB)?
 
Upvote 0

chuck3e

Active Member
Licensed User
iPhone connected to PC via internet and both devices are connected and working. I have been testing all morning then on the next test it started timing out. My PC is connected to the router via wire and phone over the air. If my PC had a bad connection I wouldn't be able to send this reply and on the iphone I can get email so I know it's working.
 
Upvote 0

chuck3e

Active Member
Licensed User
I suppose I should say installing to the phone is timing out. Also I'm going through the hosted builder. I wonder could there be a break somewhere between me and it?
 
Upvote 0

MikeSW17

Active Member
Licensed User
Perhaps you should try a a tiny "Hello World" app to see if it will load to the device. If that doesn't work, it strongly suggests something is wrong with you connection set-up rather than the size of the App.
 
Upvote 0

Albert Kallal

Active Member
Licensed User
I had one of my apps start timing out during the compile/build process
(that's good and bad!!! - good = hey, I am writing a LOT of code now!!!!).

You can try this setting;
1616641400890.png


I think the default was 30 or 60 seconds. But I bumped it up to 180. (select that option - a dialog box will pop up - you can then enter a longer time for the build process)

So, give the above a try - it is a setting, and you can as your code base grows find that the default time is insufficient for the build time/process.

the above setting fixed my experience in this regards,

Edit: hum - I missed quite much you are using the hosted builder - so, I not 100% sure above applies to your case.

Regards,
Albert D. Kallal
Edmonton, Alberta Canada
 
Upvote 0

chuck3e

Active Member
Licensed User
Thank you Erel. It is working today.

Just for the record, MikeSW17 and Albert Kallal, my .apk is only 5k, so I'm not running with you big dogs, yet.

Thank you everyone who replied to this. It's good to know there is such a helpful group.
 
Upvote 0
Top