Android Question Connect Leica DISTO via Bluetooth SPP

Steini1980

Member
Licensed User
Hi, I'm trying to communigate via Bluetooth Serial with a Leica DISTO. Pairing and receiving data from DISTO works fine, but I get an Error on DISTO after sending data via Bluetooth. It seems the DISTO is waiting for a response from Android Device for 2 Seconds else it throws Error 240, see

Documentation:
During data transmission If the data is not confirmed as being successfully received by the Pocket PC/ PC then no new measurement can be processed. The Info code "240" appears in the display if no data transmission has taken place after 2 seconds.
But how can I confirm the data as successfully received?
I can't find any further instruction. I found some documentation about other Bluetooth devices and tried sending "?<CRLF>", "a<CRLF>" and some other chars, but I get always the error after receiving data.

Has somebody an Idea or experience with DISTO or other Bluetooth devices?
May be I can use something like a Bluetooth sniffer (like whireshark, but I didn't have experience) to find out, which confirmation code is send by the original Leica app?
 

Steini1980

Member
Licensed User
No, I'm using just this serial tutorial.


Here's what I have tried to confirm the received data:

B4X:
Sub Timer1_Tick
    If connected Then
        If TextReader1.Ready Then 'check if there is any data waiting to be read
          Dim text As String = TextReader1.ReadLine
            txtLog.text = txtLog.text & text & CRLF
            txtLog.SelectionStart = txtLog.text.Length
            If text.StartsWith("@") = False Then
              TextWriter1.WriteLine("?" & CRLF)
              TextWriter1.Flush
          End If
        End If
    End If
End Sub
The Response on DISTO Display is Error 240 and App response is: "@E203".

If I search "@E203" on Google I can't found any information from Leica, but some other manuals of Bluetooth devices and "@E203" is always

Wrong syntax in command, prohibited parameter in command
entry or non-valid result, check command
I seems the Error Message is standardised so I think the syntax should also used in other devices. But everything I replied, it's the same Error.

P.S.: This documentation looks like very similar.
 
Last edited:
Top