Android Question Could not find constraint-layout.aar

Multiverse app

Active Member
Licensed User
After reinstalling B4A, one of my older projects give this error:


B4X:
B4A Version: 9.80
Java Version: 11
Parsing code.    (0.05s)
Building folders structure.    (0.02s)
Compiling code.    (0.31s)
    
ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code.    (0.05s)
Organizing libraries.    Error
Could not find file 'C:\Program Files (x86)\Anywhere Software\Basic4android\libraries\constraint-layout.aar'.

I tried downloading and placing the file from here in my libs folder, but the app crashed instantly. Any solutions?
 

DonManfred

Expert
Licensed User
Longtime User
I tried downloading and placing the file from here in my libs folder
looks wrong to me. You should add this artifact with the SDK Managaer.
Most probably you are using AndroidX so you should add the AndroidX Artifact instead of the deprecated support Artifact.

constraint018.png

but the app crashed instantly
Good idea to completely hide the error
 
Upvote 0

Multiverse app

Active Member
Licensed User
Find the library and remove it.
Seems like the error causing agent is in Firebase Realtime database by @DonManfred
Unfortunately, there's no recent version of this lib, and all the rest API classes have no realtime listening feature.

What version does this lib depend on of constraint-layout.aar ?
I tried placing all these versions in additional lib and jetifying them:

1586189760340.png
 
Upvote 0

DonManfred

Expert
Licensed User
Longtime User
What version does this lib depend on of constraint-layout.aar ?
I don´t think the library depends on it.
Maybe in the example i was using it because of the Firebase layout loading from json. I can only remember darkly...

For the FBRTDB itself you don´t need any constraint-layout.
 
Upvote 0
Top