Bug? Crash in B4A SDK Manager

Discussion in 'Bugs & wishlist' started by JohnCody, Jul 3, 2018.

  1. JohnCody

    JohnCody Well-Known Member Licensed User

    I just did my first set of downloads using the B4A SDK Manager (a lot of files - like a 100).

    Everything seemed OK.

    I then downloaded the Emulator, and two Intel file - one of these took a long time to unzip. Then when it was done, those last few emulator related items were still "checked" in the "Recommended" even though they were just installed.

    When I exited, then reran the SDK Manager I got the below error:

    Now I can't see any items to download.

    Any ideas how to fix?

    [​IMG]
     
  2. DonManfred

    DonManfred Expert Licensed User

    You did not reused an old SDK Installation and you did not used an Android Studio SDK; means you installed a new SDK using the SDK Manager in a blank folder?
     
  3. JohnCody

    JohnCody Well-Known Member Licensed User

    I had another SDK already installed by the old google sdk manager when B4A was supporting it. I never used the new B4A sdk manager until tonight because everytime I try something new or update things, it always messes up something and costs me a lot of time to fix - case in point! So, since everything was working fine, I have not used even the google sdk manager in a while (since v6 of B4A) and I guess B4A replaced it somewhere along from version 6 of B4A to v8.

    So, I now wanted to update one my apps firebase crash to crashlytics, the tutorial said I had to download all firebase file, but it appears the B4A SDK manager downloaded all the "recommended" files even though they were not visible in my search results list - which I now understand it will do that even if you do a search and think that it will only download the items visible from your search.

    I don't use B4A a ton, so I don't know a lot of the real low-level nuances, like how the SDK manager works behind the scenes. So when you say stuff like a "blank folder" I am not 100% certain what you mean.
     
  4. DonManfred

    DonManfred Expert Licensed User

    Do NOT reuse an old SDK installation. It isn´t compatible anymore.

    https://www.b4x.com/b4a.html
    Watch the Installation Video linked there. 5 Minutes.

    Follow the Installation steps precise.

    Again: Start with a new Blank Folder (like in the Video)
     
    Peter Simpson and Erel like this.
  5. JohnCody

    JohnCody Well-Known Member Licensed User

    Thank you - I will give it a try - installing each newer version of B4A never warned me about this at all :(

    I just hope all this updating and reinstalling is not going to cause other B4A projects from compiling because this is getting nuts will all these little "gotchas".
     
  6. DonManfred

    DonManfred Expert Licensed User

    I´m pretty sure you´ll get it sorted with a correct SD Installation.
     
  7. JohnCody

    JohnCody Well-Known Member Licensed User

    No good - I get the same error even with a blank directory and placing just the \tools contents in it.

    Erel, since you wrote this SDK Manager, I hope the above error line will help you figure out whats going wrong.

    Update: I created a second newer directory and it seems to be working so far (it's downloading and installing files) - I'll post back the result
     
    Last edited: Jul 3, 2018
  8. DonManfred

    DonManfred Expert Licensed User

    Create a new Thread for any Issue you have. I consider this thread closed
     
    Peter Simpson likes this.
  9. JohnCody

    JohnCody Well-Known Member Licensed User

    Creating that second blank directory worked - everything seems fine now.

    Thanks Don
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice