Android Question Default blank manifest editor code

Discussion in 'Android Questions' started by anaylor01, Aug 9, 2015.

  1. anaylor01

    anaylor01 Well-Known Member Licensed User

    I need the code for a completely blank manifest editor.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Delete all the text from the manifest editor and save it. It will return to the default text.
     
  3. anaylor01

    anaylor01 Well-Known Member Licensed User

    Ok. I did that now I get this error
    B4A version: 5.02 (1)
    Parsing code. (0.00s)
    Compiling code. (0.05s)
    Compiling layouts code. (0.00s)
    Generating R file. Error
    AndroidManifest.xml:2: error: No resource identifier found for attribute 'installLocation' in package 'android'
     
  4. anaylor01

    anaylor01 Well-Known Member Licensed User

    So I open a new B4A. I don't do anything except click RUN. It ask me to name the project. I name it test. It gets this error.
    AndroidManifest.xml:2: error: No resource identifier found for attribute 'installLocation' in package 'android'
    AndroidManifest.xml:18: error: Error: No resource found that matches the given name (at 'theme' with value '@android:style/Theme.Holo').
     
  5. anaylor01

    anaylor01 Well-Known Member Licensed User

    This is what is in the Manifest.
    AddManifestText(
    <uses-sdk android:minSdkVersion="5" android:targetSdkVersion="14"/>
    <supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
    SetApplicationAttribute(android:icon, "@drawable/icon")
    SetApplicationAttribute(android:label, "$LABEL$")
    SetApplicationAttribute(android:theme, "@android:style/Theme.Holo")
     
  6. DonManfred

    DonManfred Expert Licensed User

    which android.jar did you specified unter tools -> configure paths?
     
  7. anaylor01

    anaylor01 Well-Known Member Licensed User

    C:\Android\platforms\android-4\android.jar
     
  8. DonManfred

    DonManfred Expert Licensed User

    you should point it to the highest jar... actually 22
    You need to use at least api 14 i think
     
  9. anaylor01

    anaylor01 Well-Known Member Licensed User

    I think that worked but now AVD manger won't open.
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread for this.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice