Device/Emulator connect in designer fails with daemon error


New Member
Licensed User
Longtime User
Hi All,

I’m hoping someone might be able to point me in the right direction for an error I’m getting when I try and connect Designer to the Android Emulator.

I am attempting to run one of the tutorials that utilizes the designer. The steps listed in the tutorial are as follows:

1. Start B4A
2. Start the Emulator
3. Save the project
4. Start the Designer
5. From the designer select toolConnect to Device / Emulator

When it attempts to connect I get the following error
“An error occurred.”
** daemon still not runningerror: Cannot connect to daemon

Restarting ADB Server may solve this problem.
Main – Tools – Restart ADB server

What I have done to attempt to resolve:

I have restarted ADB, both from B4A and from a command prompt – No change
I have rebooted the computer – No change
I have turned off anti-virus – No change
I have verified that the firewall is turned off - No change
I havre plugged my Xoom into the computer and attempted to use it instead of the emulator – No change

I can open a command prompt and enter adb devices and it returns the emulator or if I have my Xoom plugged in it will return the Xoom. It appears that ADB is working correctly and that the issue is with B4A.

My current configuration is as follows:

MS Windows Professional 64-bit SP1
12GB Memory
Android SDK Tool version 1.14
Basic4Android version 2.20, (Installed over the top of the previous version)
Java 6 update 31
Java SE Development Kit 6 Update 26
Motorola Device Manager version 2.2.28

Can anybody provide any insight into what might be causing this and any possible solutions? I have read recommendations of uninstalling the Android SDK and re-installing, which seems like a bit over the top to me, as it takes hours to re-download everything with my network connection and in all the instances I found that this was recommended and tried it didn’t resolve the issue.

Any help is greatly appreciated.