Android Question Does B4A 8.00 ignore the Java path settings (or use a cache?)


Licensed User
Good afernoon

I've just installed the new Release B4A Version: 8.00
and tried to build an existing project.
B4A says:

Cannot find:
c:\Program Files (x86)\Java\jre1.8.0_141\bin\java.exe

But in Tools - Configure Paths I already have the correct Path configuration:
C:\Program Files\Java\jdk1.8.0_171\bin\javac.exe

Why does B4A use a completely different java directory?

I already have re-applied the path configuration and restarted B4A - it has still the same issue.

Thanks a lot for any help,
kind regards,


Licensed User
Longtime User
Upvote 0


Licensed User
Thank you very much, KMatle and Erel, for your support!,

I also suspected that there is not a bug but a misunderstanding - but the signs indicated that there must be a bug after all.

This was the source of the Bug:
In Main, the project has a CustomBuildAction with a path to a no longer available Java.exe.

Therefore, B4A reported that Java exe cannot be found and I overlooked the Build-Log note that it is processing the "custom action", which is more precisely the custom build action.
Upvote 0