Android Question Erro FirebaseNotification (invokedynamic requires --min-sdk-version >= 26)

Lucas Siqueira

Active Member
Licensed User
Hello everyone!

I am having the following error when compiling app with lib firebasenotification, when I remove it from the project, my app compiles, but when it is in the project, it gives the error:

B4X:
Convert byte code - optimized dex.    Error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/iid/FirebaseInstanceIdReceiver;
2 errors; aborting

1621562659818.png


I've already taken the example [B4X] [B4XPages] Firebase Push Example but still have the same problem.

I'm on version 10.70 of b4a ...
FirebaseNotification 2.00 library ...
I already updated the sdk

1621564219011.png


I tried the solution (https://www.b4x.com/android/forum/t...g-after-latest-sdk-update.130694/#post-822777), but it didn't work
 
Last edited:

Erel

B4X founder
Staff member
Licensed User
Longtime User
Something is wrong with your SDK. Delete the current Android SDK and download a new one.


Note that you don't need to update the resources.
 
Upvote 0
Top