Android Question Error after update to firebaseadmob2

tufanv

Expert
Licensed User
Longtime User
Hello,

I wanted to switch to firebaseadmob2 so used the new library, updated the required items in sdk manager to use google ads 20+ and implemented ads helper to use new messaging sstem. When I try to buid I get this error. What may be the problem?
B4X:
error: method does not override or implement a method from a supertype
   @Override
   ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 error
only showing the first 1 errors, of 2 total; use -Xmaxerrs if you would like to see more

javac 14.0.1
 

tufanv

Expert
Licensed User
Longtime User
The line on the source code giving the error is:
B4X:
   @Override
   public void onAdFailedToLoad(int arg0) {
       processBA.raiseEventFromDifferentThread(null, null, 0, eventName + "_failedtoreceivead", false, new Object[] {String.valueOf(arg0)});
   }
 
Upvote 0

asales

Well-Known Member
Licensed User
Longtime User
It is because you still using the code of the old native ads.

Check this new example:
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
It is because you still using the code of the old native ads.

Check this new example:
you are right
 
Last edited:
Upvote 0
Top