Spanish Error al conectar con Firebase Notifications: "(invokedynamic requires --min-sdk-version >= 26)"

VictorTandil

Member
Licensed User
He instalado nuevamente B4A luego de un tiempo y me he dado cuenta que todas las Apps que tenia con Firebase (FCM) no funcionan, no me permite compilar el código, arrojando el siguiente error: "Convirtiendo byte code a dex optimizado. Error Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)"

He probado iniciar un nuevo proyecto solamente con Firebase Notifications siguiendo todos los pasos que explica Erel aquí FCM pero no funciona, da el mismo error.

Erel explica una solución en este Post pero tampoco me ha funcionado.

Trate desinstalando el SDK y los Recursos e instalando todo de nuevo. Ahora compila, pero la aplicación deja de funcionar ni bien inicia y no muestra ningún tipo de error.
 

José J. Aguilar

Expert
Licensed User
Hola:

Me pasó lo mismo, y la solución pasa por seguir cuidadosamente las instrucciones de instalación


saludos,
 
Top