Error at line 0?

Discussion in 'Questions (Windows Mobile)' started by Mistrel, Oct 18, 2007.

  1. Mistrel

    Mistrel Member

    I'm trying to run RandomCoder's icon editor on my Dell Axim X3 and I'm getting the following error

    If I hit yes to continue the program ends silently.

    I can run this program fine on my desktop but it doesn't work at all on my pocket pc. Does anyone else have this problem?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    I don't know what is the problem with the specific application.
    There is a bug that causes compiled applications to always show line number 0 as the error line.
    It will be fixed in the next version.
     
  3. RandomCoder

    RandomCoder Well-Known Member Licensed User

    Erel, the application wasn't compiled (unless Mistrel compiled it).
    I didn't experience any problems with it on my device, I'm using an Axim X51v with WM5.

    Mistrel
    Hope you get it working and have more success than I did at finishing the project. My next objective was to try and get an icon to load into the editor and if I managed that I was going to try and save the created icon back to a file.
    I'm pretty sure there must have been an easier way of approaching the problem, maybe I just made it too difficult for myself?

    Have fun with it anyway and feel free to modify it to your own needs.

    Regards,
    RandomCoder.
     
  4. HarleyM

    HarleyM Member Licensed User

    I'm getting the same error with my program...

    Originally written in ver 4, converted to ver 5, runs fine on the desktop but has the same error as Mistrel. the only thing I can think of is that I recently upgraded the rom on my Jasjam to WM6 (schapps 3.60a cooked rom). This is the first time I've had a problem running software on it. Everything else has been given a new lease on life, running faster & without problems that I had originally with the original Rom.
     
  5. HarleyM

    HarleyM Member Licensed User

    Something else to consider...

    having failed to run the compiled app on my device, I copied across the source & attempted to run that on the devices programming environment. This time I got the error :
    Error loading external library :
    An error message cannot be displayed because an optional resource assembley containing it cannot be found.

    I'm suspicious that one (or more) of the libraries used by my program is not working with MW6.
    These are :
    treeview.dll
    Hardware.dll
    RegistryDevice.dll
    FormLib.dll

    I'll have to see whether these may have been upgraded since the 5.5 release
     
  6. Erel

    Erel Administrator Staff Member Licensed User

  7. HarleyM

    HarleyM Member Licensed User

    Sorry Erel...

    System_SR_ENU_wm.cab made no difference to the error messages received either by running my desktop compiled program (errror at line 0) or through running within the device's developer(optional resource asembly not found).:sign0148:
     
  8. taximania

    taximania Well-Known Member Licensed User

    I tried to install that cab and got a

    'Setup Failed'
    System_SR_ENU_wm.cab is not a valid Window CE Setup file. :sign0163:
     
  9. HarleyM

    HarleyM Member Licensed User

    Finally got around to trying it all again...

    This time I did get a few more clues. My program has a problem with treeview.dll which I now suspect must have been dropped in the latest versions of basic4PPC as I haven't got the library files anymore following the 5.8 upgrade. Can someone let me know what has happened/possible fix. I'm obviously not up with the play.

    Cheers.

    Ok figured out what I needed was another library for external libraries. Where would I be without this forum & it's ability to search right back... Thanks Erel for a great program & support
     
    Last edited: Nov 3, 2007
  10. Erel

    Erel Administrator Staff Member Licensed User

    Just to make it clear, all the controls libraries were merged to one library named ControlsEx library.
     
Loading...