Error compiling - CEnhancedListbox ???

Discussion in 'Questions (Windows Mobile)' started by Julius, Feb 15, 2009.

  1. Julius

    Julius Member Licensed User

    Hello!
    I am a new user. I am using a registered version 6.5 with Windows Vista 64bit.
    I started very successful with a little program for my wife's PPC, calculating weightwatchers points and daily sums. My life loves it.
    Now I made a little improvement to use a variable loop counter instead a fixed one (line 74). That's all. And no compiling where possible despite the debug running works fine.
    The source code will not compile in the optimized mode (as I did before. Only the none-optimized mode is running after installing network 1.1)
    The cause can't be the source code. Klaus from the german forum tried it without problems. And I get the same error just with an one line test program.

    I got the message (translated from german): "Error CS0246: The type and Namespacename CEnhancedListbox could not be found (a directive or assemply pointer/reference is missing?) " And the line with the error is listed, but that is definitely not the cause.
    I am sure it is any missing or wrong located system-file. Maybe any Vista 64bit speciality? Maybe user-account specific? This is what I modified recently.

    Attached is the source code and the used csv-file. -->I can't add it, because they are some bytes too large ?? The zip-files are 4 and 2 KB large

    kind regards
    Julius/Peter
     
  2. agraham

    agraham Expert Licensed User

    Upload to the forum was broken for a while. Erel has now fixed it - try again!
     
  3. Julius

    Julius Member Licensed User

    Error compiling

    I will add my both files here. The source code .sbp and the data file .csv (as zip-file, .csv was not possible)

    kind regrds
    Peter Eckmann
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    I've compiled your code on a Vista 64bit computer and it compiles fine.
    Maybe there is a security problem.
    Please go to basic4ppc folder: C:\Program Files (x86)\Anywhere Software\Basic4ppc Desktop.
    Right click on Dbasic.exe and choose Run As Administrator.
    Try to compile your application and see if it helps.
     
  5. Julius

    Julius Member Licensed User

    e

    Perfect!!
    That solves the problem.

    kind regards
    julius/Peter
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice