Android Question error on LameEncoder (liblame 1.01)

scsjc

Well-Known Member
Licensed User
Hello,
im use the library liblame 1.01 on my project, to record audio, on a Benq Aquaris_M5, get this error...
can i fix????
thanks !!!!

B4X:
java.lang.UnsatisfiedLinkError: dlopen failed: /data/app/myworldapp.people.com-1/lib/arm/liblame.so: has text relocations
    at java.lang.Runtime.loadLibrary(Runtime.java:372)
    at java.lang.System.loadLibrary(System.java:1076)
    at net.sourceforge.lame.Lame.<clinit>(Lame.java:36)
    at com.intervigil.lame.Encoder.initialize(Encoder.java:52)
    at uk.co.martinpearman.b4a.liblame.EncoderWrapper.SetFiles(EncoderWrapper.java:92)
    at myworldapp.people.com.chat._micropanel_touch(chat.java:1678)
    at java.lang.reflect.Method.invoke(Native Method)
    at anywheresoftware.b4a.BA.raiseEvent2(BA.java:169)
    at anywheresoftware.b4a.BA$1.run(BA.java:293)
    at android.os.Handler.handleCallback(Handler.java:739)
    at android.os.Handler.dispatchMessage(Handler.java:95)
    at android.os.Looper.loop(Looper.java:148)
    at android.app.ActivityThread.main(ActivityThread.java:5417)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
 

scsjc

Well-Known Member
Licensed User
can't i fix with this solution because i have the project on playstore with a targetSdkVersion="23" :( and can't downgrade on playstore
can have another solution???? or another library ????
thanks !!!!!
 
Upvote 0
Top