iOS Question "Error opening stream" in debug mode


Active Member
Licensed User
On Friday I updated one of my test phones to iOS 11.0.3. I'm running B4i 4.4 Beta 1.
The other test phone is running 10.3.3.

This morning, I made some tweaks to my app, and tried running in debug mode.

I got an error on the line


which was fine last week. I checked, and the file's still there. Full text of the error is

Error opening stream: Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory" UserInfo={_kCFStreamErrorCodeKey=2, _kCFStreamErrorDomainKey=1}

I opened the file in the designer, then did "Save as" and gave it a new name, and updated the code. Now, the app gets past LoadLayout, but fails with the same error on the next line

bluflogo.Bitmap = LoadBitmap(File.DirAssets,"blufblacktrans.png")

The app runs fine in build mode. I've tried a reboot (sometimes, as my source is on a NAS, that helps if it's a locked file). No change. Cleaning the project made no difference either.

I then dug out the old phone, swapped the debug to 32 bit, and everything is fine. Swap back to 64 bit, 11.0.3 and the error appears again.

Anyone else seeing weird stuff like this?