iOS Question Existing apps crash compiling with version 6.80

sdesan

Member
Licensed User
Hi,
i have installed version 6.80 and renewed all certificates and profiles on developer.apple.com then I have simply reopened a couple of existing app (with simple few text only modification) actually published whitout any problem on apple store. Last compilation on remote hosted builder 10 month ago.

I have recompiled, without any problem, and installed using B4i-Bridge both app on my iphone but when i start app it closes immediatelly, i thing for a crash.
I have also made app release , without any problem, and published on app store but i have received this message and the attache chash dump.

We were unable to review your app as it crashed on launch. We have attached detailed crash logs to help troubleshoot this issue.

In logs section of B4I main program i not have any error or warning message.
If i start a new app it works whitout any problem
I thing that problem is in some library with remote compiler (or in certificate?!? but i ckech all with https://www.b4x.com/android/forum/threads/creating-a-certificate-and-provisioning-profile.45880/)
Those apps are on store from 2016 and are compiled with variuos release of b4i without any problems

Library used in first app are
1601140695831.png


in second one
1601140768886.png


I'm unable to understund what is the problem. Can ayone help me?

Thank you
Sergio De Santis
 

sdesan

Member
Licensed User
A little add:
if also in a new app i use iAdMob with a wildcard identifiers (for developing use) on compiling i receive this error

note: Using new build system
note: Planning build
note: Constructing build description
error: Provisioning profile "All development" doesn't support the In-App Purchase capability. (in target 'B4iProject' from project 'B4iProject')

but In-App Purchase is not selectable in wildcard mode so i need to use an explicit identifiers for every app during development.

Maybe all my problems are connected with iAdMob
 
Upvote 0

sdesan

Member
Licensed User
Hi Erel and thank you for the answer.
I think i don't have used any Plist in my code.
I'm focused on adMod: is any recent working example of correct using of AdMod?
 
Upvote 0

sdesan

Member
Licensed User
I confirm that problems is connected to library iAdMob (i have 1.71 version)
if i simply add iAdMob Library on any app that works without any problem, it crashes
In my code i write:
B4X:
Sub Process_Globals
    'These global variables will be declared once when the application starts.
    'Public variables can be accessed from all modules.
    Public App As Application
    Private princi1 As Page
    ...
    Private ImageView1 As ImageView
    Dim adview1 As AdView
    ...
End Sub

For displaing Ads i write

B4X:
Sub ImageView1_Click
    princi1.RootPanel.LoadLayout("princi")
    SetMultiline(parcomaiella)
    SetMultiline(parconalm)
    adview1.Initialize("Ad","ca-app-pub-58072950308****************",princi1,''adview1.SIZE_BANNER)
    adview1.LoadAd
    adview1.Alpha = 1
    adview1.Visible = True
    adview1.BringToFront
    princi1.RootPanel.AddView(''adview1, 0dip, altezza-50dip, 100%x, 50dip)
    NavControl.ShowPage(princi1)
End Sub

but problem is not in code but in library:

  1. is library corrupt?
  2. i need a new version of library?
  3. is changed something in using Ads on iOs app?
In current version of app published on store the Ads appear whit out any problem:(
Thank you
 
Upvote 0

sdesan

Member
Licensed User
SOLVED
I had to add those lines

B4X:
#Region  Project Attributes
    ...
    
    #PlistExtra: <key>GADIsAdManagerApp</key><true/>
    #AdditionalLib: libsqlite3.dylib
    #AdditionalLib: libz.dylib
    #AdditionalLib: WebKit.framework
#End Region

:)
 
Upvote 0
Top