Android Question Facebook login SignedIn event does not fire on some phones

Discussion in 'Android Questions' started by biometrics, Apr 22, 2019.

  1. biometrics

    biometrics Active Member Licensed User

    Hi,

    I'm using the Google and Facebook login as detailed here: https://www.b4x.com/android/forum/t...rebaseauth-to-support-facebook.67954/#content

    It's working well on a Sony Z3 and a Oneplus 6T but on a Samsung Galaxy S6 with Android 7.0 the Facebook SignedIn event doesn't fire. Google login works on the S6.

    In the log I see this entry:

    Code:
    Facebook success: com.facebook.login.LoginResult@a404f72
    I tried logging out from the Facebook app. Then when running:

    Code:
    auth.Initialize("auth")
    facebook.Initialize
    facebook.SignIn
    It displays the Facebook login dialog. Once logged in the SignedIn event still doesn't fire.

    Any ideas?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Don't you see a message starting with: signInWithCredential ?
     
  3. biometrics

    biometrics Active Member Licensed User

    I'm not sure. Unfortunately the client has left with his Samsung S6 and he's lives in another city. I wonder if I can remotely do a debug session. Which port do you use for the bridge so I can get him to set up port forwarding on his router? I'll get the full log for you then.
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    B4A-Bridge listens on port 6789. However this will not be enough for the logs. It will be easier to capture the logs with LogCat and send them.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice