German Fehler bei der Installation einer App

jsk001

Member
Licensed User
Hallo,
ich habe seit dem Letzten Update meines Samsung Galaxy A12 (Android 11) das Problem, dass
meine App zwar sauber erstellt wird (Ordner Objects) aber die Installation auf das Gerät nicht.
mehr funktioniert. Manuello lässt sich die App problemlos installieren.
Aus B4a ich bekomme folgende Ausgaben.

--------------------------------------------------------------
B4A Version: 11.00
Parse den Code. (0.05s)
Java Version: 11
Building folders structure. (0.01s)
Kompiliere den Code. (0.06s)
Kompiliere Layoutcode. (0.00s)
Organisiere Libraries. (0.00s)
(AndroidX SDK)
Ressourcen zusammenstellen (0.10s)
Ressourcen verknüpfen (0.41s)
Kompiliere generierten Java Code. (0.02s)
Byte-Code konvertieren - optimiert dex. (1.73s)
Kopieren von Bibliothek Ressourcen (0.70s)
ZipAlign file. (0.31s)
Signiere Paketdatei (debug Key). (0.98s)
Installiere Datei auf Gerät. Error
Der angeforderte Vorgang erfordert erhöhte Rechte
------------------------------------------------------------

Ich vermute ein Problem mit ADB. Beim Neustart des ADB Server bekomme ich folgende
Fehler-Ausgabe.

[IDE message - 12:02:58]
Ein Fehler trat auf.
Der angeforderte Vorgang erfordert erhöhte Rechte

Ich habe JDK, B4a Commandline-Tools und Ressources nach Anleitung neu auf den Rechner
in die vorgeschlagegen Ordner gezogen. Der Fehler bleibt. Andere Java-Installationen sind nicht drauf.
Ich habe jetzt 3 Wochen nicht an meiner App gearbeitet. Vorher gab's keinerlei Probleme.
Jetzt ???
Ich hoffe, dass mir jemand eventuell einen Tip geben kann.
Danke im Voraus.

Nachtrag; Das Problem tritt sowohl bei Verbindung über B4a-Bridge mit Wlan auf als auch bei
Verbindung über USB-Kabel.
 
Last edited:

pucki

Active Member
Licensed User
Poste mal dein Manifest. In 90% aller Fälle liegt da der Fehler.

Ich würde aus den Bauch heraus mit Hilfe der Glaskugel vermuten das die Android-Version nicht stimmt.

z.b. <uses-sdk android:minSdkVersion="5" android:targetSdkVersion="19"/> <- da was falsch eingestellt.

Vergesse ich auch öffters zu ändern. ;)


Gruß

Pucki
 

jsk001

Member
Licensed User
Danke für eure Tips. Die alte Version des Programms habe ich vorher gelöscht.
Hier das Manifest:

AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="29"/>
<supports-screens android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true"
android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>)
SetApplicationAttribute(android:requestLegacyExternalStorage, true)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
CreateResourceFromFile(Macro, Themes.LightTheme)

Ich denke dass ich ein Problem Mit ADB unter Windows 10 habe. Beim Neustart des
ADB-Server in B4a (aktuelle Version) rennt b4a jedesmal ins Timeout und B4a friert ein (freeze) bis
nach dem Timeout.
Das Programm wird sauber compiliert und liegt unter /objects. Es kann dann manuell
installiert werden.
Lediglich die Installation auf das Gerät unter B4a ist nicht möglich. Inzwischen habe ich versucht ADB-Server
von der Kommandozeile zu starten. Schon das geht nicht. Bei "adb devices" ...keine Reaktion.
Die Umgebungsvariable ist gesetzt. Unter der Bedingung kann natürlich die Installation auf das Gerät
von der B4a.exe nicht gehen. Ich freue mich über jede Idee von euch.

Der ADBdriverInstaller zeigt dass dass Gerät erkannt wirt. Im Gerätemanager stehts auch drin.
 

Attachments

  • Image1.jpg
    Image1.jpg
    56.7 KB · Views: 21

klaus

Expert
Licensed User
Es scheint dass diese Zeile Probleme erstellt gemäss HIER:
SetApplicationAttribute(android:requestLegacyExternalStorage, true)
Zugriff auf externe Speicher wird von Google mehr und mehr begrenzt.
 

jsk001

Member
Licensed User
Es scheint dass diese Zeile Probleme erstellt gemäss HIER:
SetApplicationAttribute(android:requestLegacyExternalStorage, true)
Zugriff auf externe Speicher wird von Google mehr und mehr begrenzt.

Hallo Klaus,
Danke für den Hinweis, aber auch ohne den Eintrag im Manifest bleibt das kompilieren an der
Stelle stehen. Irgendwie scheint ADB bei mir nicht mehr zu funktionieren. Das Programm liegt immer
sauber unter /objects und funktioniert nach manueller Installation auch sauber. Irgendwie scheint mir
ein Windows Update vielleicht die Ursache des Problems zu sein. Ich habe aber kein gutes Gefühl einen
alten Wiederherstellungzeitpunkt des Systems zu aktivieren.
ADB devices zeigt mir kein Gerät an obwohl es (siebe Bild weiter oben) sauber erkannt wird.
 

jsk001

Member
Licensed User
Das aktuelle SDK ist das ..jre1.8.0_311. Das ist installiert.
Auch das im B4a Installation Thread vorgeschlgagene jdk-11.0.1
ist unter c:\java verfügbar und im Pfad eingestellt.
 

jsk001

Member
Licensed User
Ich bin noch einmal exakt so vorgegangen. ADB funktioniert trotzdem nicht.
Ich war eine Zeit lang im Krankenhaus. Davor hat alles sauber funktioniert.
Windows hat danach ein paar Updates gemacht. Das war's mit ADB.
Ich schmeiß jetzt mal der Reihe nach die letzten Updates runter und schaue
was passiert.
 
Top