Android Tutorial Google Play: "Designed for tablet screens"

Informatix

Expert
Licensed User
A change is coming up on November 21 on Google Play. The applications considered by Google as not designed for tablets will be marked as designed for phones and, by default, won't appear for tablets (a setting will allow to switch to the former view, with all apps, but we can bet that most users won't change it). For B4A users, the minimum things to do to make an app "designed for tablet screens" are:
- set android:largeScreens to true in the Manifest editor (it is true by default);
- set targetSdkVersion to 11 or higher in the Manifest editor (it is set to 14 in new projects);
- add a folder \Objects\res\drawable-hdpi to your project and place the icon.png (minimum size 72x72) of your app inside;
- import at least two screenshots in the Tablet section (7" and 10") of the Google Play console.
 

Harris

Expert
Licensed User
I don't have a (functional) 10 inch tablet. (and "Send to Cloud" gives me an error on my bg.jpg file)

How do I get a screen shot?

Thanks
 

Harris

Expert
Licensed User
Which error do you get with the UI cloud? The file is too large? You can temporary replace it with a smaller image.
I shall try replacing it and see what happens. 100 k I believe...
 

Harris

Expert
Licensed User
Yes, file at 88 k too large.
I reduced to 15 k and works fine. However, I have a (help) panel set Visible = false. It contains a label with help text. It shows through when sent to cloud.
 

David Rynn

Member
Licensed User
A change is coming up on November 21 on Google Play. The applications considered by Google as not designed for tablets will be marked as designed for phones and, by default, won't appear for tablets (a setting will allow to switch to the former view, with all apps, but we can bet that most users won't change it). For B4A users, the minimum things to do to make an app "designed for tablet screens" are:
- set android:largeScreens to true in the Manifest editor (it is true by default);
- set targetSdkVersion to 11 or higher in the Manifest editor (it is set to 14 in new projects);
- add a folder \Objects\res\drawable-hdpi to your project and place the icon.png (minimum size 72x72) of your app inside;
- import at least two screenshots in the Tablet section (7" and 10") of the Google Play console.

Hello,

I did all these settings but when I run "Debug" or "Release" the \Objects\res\drawable-hdpi folder and contents disappears and is not built into the application. Is it possible to find out why?

Thanks.
 

Informatix

Expert
Licensed User
Hello,

I did all these settings but when I run "Debug" or "Release" the \Objects\res\drawable-hdpi folder and contents disappears and is not built into the application. Is it possible to find out why?
Set the read-only attribute for the icon file.
 

David Rynn

Member
Licensed User
Thanks. That part is working now. However I still get an error on the Google Play Developer Console stating "Your APK should include custom drawables assets for common tablet screen densities." :(
 

Informatix

Expert
Licensed User
Thanks. That part is working now. However I still get an error on the Google Play Developer Console stating "Your APK should include custom drawables assets for common tablet screen densities." :(
What's the size of your icon.png in the hdpi folder? It needs to be 72x72.
And what do you have in your \Objects\res\drawable folder?
 

David Rynn

Member
Licensed User
OK. All is fine now.

I deleted my app from the Google Developer Console and added it again. Google now recognises it as a Tablet App. I guess there was something lurking in the Cache on the Google Website.

Thank you for your help.
 

Harris

Expert
Licensed User
Are you sure that you are not setting its Visible property to True in the script?
No, I looked for that first thing. Visible is false.
 
Top