Android Question Google says I'm using targetSDKVersion 26

Markos

Active Member
Licensed User
Hi All,

I have in my manifest the following line block:
AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="28"/>
<supports-screens android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true"/>)

Yet I just received a report from Google stating it is set at
targetSdkVersion=26

is this an error on the part of google or have I updated the manifest incorrectly.

I'm using Android28 and set in configure paths at :
C:\Android\platforms\android-28\android.jar

Should I used C:\Android\platforms\android-29\android.jar in case there is some confusion in android.jar versions?
 

tufanv

Expert
Licensed User
I received the same email from google altough mine is 28. I assumed that it is because of an apk in beta release is using the 26 , mail states that "in production or testing tracks- so you probably have a apk in beta,alpha or some testing track, I don't think what you did can resolve the issue.

anyone knows how I can remove the apk from beta, I can't move it to production as it is an very old version and I cant delete it.
 
Upvote 0

Markos

Active Member
Licensed User
I received the same email from google altough mine is 28. I assumed that it is because of an apk in beta release is using the 26 , mail states that "in production or testing tracks- so you probably have a apk in beta,alpha or some testing track, I don't think what you did can resolve the issue.

anyone knows how I can remove the apk from beta, I can't move it to production as it is an very old version and I cant delete it.
I'm pretty certain not all of my aps were in beta and all giving weird notice in sdkversions 19 to 26. It may be some other quirk but once I put compilesdkversion=28 the problem was resolved. It may also be attributed to when I compiled in b4a9 vs b4a9.5 so it may be that but no energy to determine which was the true culprit just glad I don't have to worry about my apps being suspended or some sillyness.

On your question you can try uploading a new version and see if it gives you the option to delete one or both
 
Upvote 0

tufanv

Expert
Licensed User
I'm pretty certain not all of my aps were in beta and all giving weird notice in sdkversions 19 to 26. It may be some other quirk but once I put compilesdkversion=28 the problem was resolved. It may also be attributed to when I compiled in b4a9 vs b4a9.5 so it may be that but no energy to determine which was the true culprit just glad I don't have to worry about my apps being suspended or some sillyness.

On your question you can try uploading a new version and see if it gives you the option to delete one or both
How do you know that the problem resolved ? Where do you see that is resolved becqause I can obly see the problem with the received mail
 
Upvote 0

Markos

Active Member
Licensed User
How do you know that the problem resolved ? Where do you see that is resolved becqause I can obly see the problem with the received mail
When in the developer console I goto the App in question and check APK details and it states what API SDK it is using and it states 28.
 
Upvote 0
Top