German GoogleMaps

Discussion in 'German Forum' started by Silvio76, May 10, 2015.

  1. Silvio76

    Silvio76 Member Licensed User

    Hallo, ich bin der Silvio und ich bin neu hier und habe auch direkt eine Frage. ;-)
    Ich benutze B4A V4.30.

    Ich bin gerade dabei folgendes Tutorial durch zu arbeiten:
    http://www.b4x.com/android/forum/threads/google-maps-android-v2-tutorial.24415/

    Pfad.JPG

    Habe alles so gemacht, wie es in der Beschreibung steht, ich bekomme jedoch immer wieder folgende Fehlermeldung bei der Ausführung:

    Fehler.JPG

    Kann mir jemand sagen, woran das liegt, wo mein Fehler ist?

    Vielen Dank bereits für eure Hilfe.
     
  2. klaus

    klaus Expert Licensed User

    Wo hast Du das Android SDK gespeichert ?
    Je nach dem wo das ist, musst Du diese Zeile danach anpassen.
    Der Anfang kann anders sein, bei mir sieht er so aus:
    #AdditionalRes: C:\Android\extras\google\google_play_services\libproject\google-play-services_lib\res, com.google.android.gms
     
  3. Silvio76

    Silvio76 Member Licensed User

    Der Pfad, den ich angegeben habe, der passt... da liegen die Dateien.
     
  4. klaus

    klaus Expert Licensed User

    Und die Fehlermeldung sagt das Gegenteil !?
     
  5. Silvio76

    Silvio76 Member Licensed User

    Pfad2.JPG

    Ja, genau da liegt mein Problem.
     
  6. klaus

    klaus Expert Licensed User

    Im Tutoriel ist am Ende:
    ...google-play-services_lib\res, com.google.android.gms
    Du hast aber:
    ...google-play-services_lib\libs, com.google.android.gms
     
  7. Silvio76

    Silvio76 Member Licensed User

    Hallo Klaus,

    vielen Dank für deine Hilfe, aber egal ob \res, oder \libs am ende steht... es funktioniert leider nicht, obwohl die Dateien vorhanden sind. Immer wieder oben stehende Fehlermeldung.

    LG.
     
  8. eurojam

    eurojam Well-Known Member Licensed User

    Hallo Silvio,
    hast Du denn die Datei google-play-services.jar (diese steht in C:\<android sdk>\extras\google\google_play_services\libproject\google-play-services_lib\libs) auch in den Library Ordner (etwa in der Art C:\Programme\Anywhere Software\Basic4android\Libraries) von b4a kopiert? So wie Klaus sagt, musst Du als AdditionalRes ...google-play-services_lib\res, com.google.android.gms angeben. Ich habe bereits einige Projekte damit gemacht, das funktioniert immer prima.

    VG
    stefan
     
  9. Silvio76

    Silvio76 Member Licensed User

    Hallo Eurojam,

    ja, auch dort liegen die Dateien, ich habe es gerade nochmal probiert, aber immer noch dasselbe Problem:

    B4A version 4.30
    Parsing code. 0.02
    Compiling code. 0.10
    Compiling layouts code. 0.00
    Generating R file. Error
    invalid resource directory name: C:\Android\android-sdk\extras\google\google_play_services\libproject\google-play-services_lib\res google-play-services.jar
    invalid resource directory name: C:\Android\android-sdk\extras\google\google_play_services\libproject\google-play-services_lib\res google-play-services.jar.properties

    Hier der Code:

    #Region Project Attributes
    #ApplicationLabel: B4A Example
    #VersionCode: 1
    #VersionName:
    'SupportedOrientations possible values: unspecified, landscape or portrait.
    #SupportedOrientations: unspecified
    #CanInstallToExternalStorage: False
    #AdditionalRes: C:\Android\android-sdk\extras\google\google_play_services\libproject\google-play-services_lib\res, com.google.android.gms
    #End Region

    #Region Activity Attributes
    #FullScreen: False
    #IncludeTitle: True
    #End Region

    'Activity module
    Sub Process_Globals


    Vielen Dank für eure Hilfe und einen guten Wochenstart.
     
  10. eurojam

    eurojam Well-Known Member Licensed User

    Hallo Silvio,
    wie groß ist denn die google-play-services.jar Datei (sollte so 3,4 MB haben)? Ich hatte da auch Mal Probleme mit einer fehlerhaften Installation des SDK. Also Neuinstallation versuchen.
     
  11. Silvio76

    Silvio76 Member Licensed User

    Hallo eurojam,

    vielen, vielen Dank für den Tip. Wahrscheinlich war es eine fehlerhafte Installation. An der Dateigröße hat sich nach einer Neuinstallation absolut gar nichts geändert und ich hab gedacht... das brauchste gar nicht probieren... funzt eh nicht... Aber... es funktioniert.

    Vielen Dank Dir und auch Klaus für eure tolle Hilfe!!!!!!!!!

    VG Silvio
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice