B4J Question in-line code options

Daestrum

Well-Known Member
Licensed User
Is there a way to specify which version of Java source I am using?

I am currently getting error messages complaining about using diamond operators and try-catch blocks in the in-line code.
The error suggests I add the option "-source 7" but where can I add this ?

The error :-

javac 1.8.0_25
src\b4j\example\main.java:101: error: diamond operator is not supported in -source 1.5
private static List<String> foundIn = new LinkedList<>();
^
(use -source 7 or higher to enable diamond operator)
1 error
 
Last edited:
Top