Is there really a problem with 64 bit JDK?

PhilipBrown

Active Member
Licensed User
According to the installation instructions:

Select "Windows x86" in the platforms list (for 64 bit machines as well). Android SDK doesn't work with Java 64bit JDK. You should install the regular JDK for 64bit computers as well.
But I am running under Windows 8 with Java 64bit JDK and so far I haven't had any problems.

So does this advice still apply?
 

James Chamblin

Active Member
Licensed User
I have Windows 8.1 and it will not allow me to install 32 bit JDK so I installed the 64 bit version. The Android SDK could not find JDK, but if you set an environment variable called JAVA_HOME and point it to the JDK directory (in my case, it was "C:\Program Files\Java\jdk1.7.0_51\"), then Android SDK can find it. Already compiled the math tutorial in the beginners guide to verify it works. Hope this helps people with installing B4A in the future.
 

Askjerry

Member
Licensed User
You have... "set an environment variable called JAVA_HOME and point it to the JDK directory"

There are those among us... like me... who don't have a clue what that means. Can you please give us a step-by-step set of directions so we can do that? I have Windows-7, so I am currently downloading the 86 version instead of the 64 version... but for others who have the Windows-8 issues... and don't know what an environment variable is, or where to set it... it could be helpful.

Is it a registry thing? Seriously... no clue here. I looked it up... http://en.wikipedia.org/wiki/Environment_variable and have a foggy idea... but hey, I'll admit it... what?

UPDATE: James Chamblin provided the answer...

Press the Windows key + Pause/Break key to bring up the System dialogue. On the left, Click Advanced system settings to bring up System Settings dialogue. Under the advance tab, at the bottom, click on Environment Variables. In the section marked System Variables, click on new. Variable name should be JAVA_HOME. Variable value should be the path to your JDK install C:\Program Files\Java\jdk1.8.0_05\ . Android SDK should now install.
Thanks for that!
Jerry
 
Last edited:
Top