Android Question Issue while trying to run the Rapid Debug

BenF

Member
Licensed User
Hi guys,
I tried to get back to a project that I haven't worked on in a few months (I've changed computers, filing systems etc, if that might have an impact), and when I tried to run the rapid debug it threw an error, halting the debug before it could run.

B4X:
Parsing code.                           0.06
Compiling code.                         1.50
Compiling layouts code.                 0.48
Generating R file.                      2.58
Compiling debugger engine code.         Error
javac 1.7.0_71
shell\src\b4a\example\main_subs_0.java:11: error: method PushSubsStack in class Debug cannot be applied to given types;
        Debug.PushSubsStack("Activity_Create (main) ","main",0,main.mostCurrent.activityBA,main.mostCurrent,363);
             ^
  required: String,String,int,RemoteObject,Object
  found: String,String,int,RemoteObject,main,int
  reason: actual and formal argument lists differ in length
1 error
I'm assuming it has something to do with an error in the Activity_Create sub, but I have tried commenting it back to practically nothing and it still runs into the same problem. Could it be a B4A version issue, as I have had to reinstall (I am currently on V3.82, and first started this project around April or May)? Or maybe an issue that has arisen in the process of copying files from the old computer to the new one?

I am able to run it as a release to emulators or devices, and although there are still some issues (incomplete project and all), it does seem to get through everything in Activity_Create without issue.

Any thoughts or solutions would be greatly appreciated.

Cheers,
BenF
 

BenF

Member
Licensed User
Thanks for the quick responses guys, and sorry for the delay in seeing them, I've been out of the office.
Erel, would it just be a matter of downloading the correct library, or will I have to re-install B4A?
 
Top