Android Question Issues in Installing B4A on X64 Machine


I am a novice and this is my first post/question. Please correct me if I am posing the question at wrong place.

I downloaded B4A few days before and tried installing on my 64 bit machine. I tried uninstalling java64 bit and reinstalling 32 bit version and made multiple attempts but there is no success.

This morning I cleaned up my machine by uninstalling almost all softwares (except office and few critical apps). But again while installing i end up with the question due to contradicting statements on B4A website and B4A documentation.

On B4A website (@ it states,

"Select "Windows x86 (32-bit) or Windows x64" in the platforms list."

In contrary to this,

On B4A documentation - Beginners Guide (edition 2.9 updated on 2014.06.03) page 10, states that
'Select "Windows x86" in the platforms list (for 64 bit machines as well)'

I attached screen captures for reference.

Since my earlier attempts failed, I want to clarify if I am doing right thing. IS there a latest guide available? I appreciate your inputs.

Thanks in advance


  • Website.PNG
    28.8 KB · Views: 87
  • Guide.PNG
    35.7 KB · Views: 92
Thank you for the reply. I installed with X64 and working fine now. I wish someone update the document.

I seem to have some teething problems on emulator but will explore it.
Upvote 0
Thank you for the advice. I installed Genymotion and it is indeed faster. But I am stuck with a question.

I am able to load and run "MyFirstProgram" smoothly on device emulated by Genymotion. Happy until here. (so I think, my setup is correct. :-D)

But when I tried writing a simple "Hello World" application, I am not able to run. I verified the folders for the availability of layout file and it exists. I tried giving complete path for the file but no success.

Please help me. I attached screen capture images both for B4A and Emulator screens.

Thanks in advance


  • B4A Prg Error.PNG
    B4A Prg Error.PNG
    39.3 KB · Views: 101
  • B4A Prg Error on Emulator.PNG
    B4A Prg Error on Emulator.PNG
    54 KB · Views: 104
Upvote 0