Android Question JdbcSQL, getting parameter index out of range using the example


New Member
Hello, so i downloaded the example for JdbcSQL from i replaced the username, password, server ip and database name with my own (i have the mysql server running on my PC) and the connection goes through just fine. i also tested connecting from a different PC in a different network to the server just to make sure everything works fine. thing is when it comes to executing a query, i always get success = false. i even tried ridiculous queries that should always work like "select true" but those still fail.
i checked the unfiltered logs and i found this error (check image). it pops right as i execute the query the line in yellow

i googled around a bit for the error but really couldnt find much that made sense for my case. thanks!

edit: apparently the issue was with the array, i gave it a null and it worked fine but no idea why? is the example wrong or maybe i was expected to change the array value since im new i wouldnt know
Last edited: