Android Question KeyValueStore missing library

Roger Daley

Well-Known Member
Licensed User
Hi All,

I'm trying to use KeyValueStore for the first time, following the tutorial. I get to step 1 declaring kvs and the IDE tells me I'm missing a library. After going backwards and forwards to the tutorial and searching the forum I'm stumped. Attached are screen shots of my code and the example in the turorial, hopefully someone can see what I can't.

Thanks in advance
Regards Roger

MyCode.jpg KeyValueStoreExample.jpg
 

DonManfred

Expert
Licensed User
Unfortunately keyvaluestore.bas is already existing
it may exists in the folder of your project. BUT it is NOT ADDED to your project. I cannot see a module keyvaluestore in your screenshot. Check your posted screenshots and compare them... in your project (configulator) you dont see the keyvaluestore entry in modulebar. In your screen from KVS example it is shown.

Use
addmodule001.png


and then select the keyvaluestore.bas from your projectfolder. Try to compile again after your have added the module


See this Screenshot from keyvaluestore-example
addmodule002.png

This is how it must look like in the modulebar
 
Last edited:
Upvote 0

Roger Daley

Well-Known Member
Licensed User
DonManfred

I think you are right about the module not being loaded correctly but getting there isn't working. It doesn't want to be added.
I've deleted the file, restarted the PC and restarted the program. The result is the same.

Result.jpg

Regards Roger
 

Attachments

  • ADD1.jpg
    ADD1.jpg
    78.7 KB · Views: 59
Upvote 0

Roger Daley

Well-Known Member
Licensed User
DonManfred/James

All OK! I did another restart and with only the IDE up I ADDED the keyvaluestore.bas file from the example directory. I can speculate that previously I have had the Example loaded and my code was helping itself, confusing the IDE. [That's only a guess]

Thanks for your help
Regards Roger
 
Upvote 0
Top