Android Question [lib] liblame - UnsatisfiedLinkError: dlopen

scsjc

Well-Known Member
Licensed User
Hi,
i receive this error, i think is from a library Liblame...



B4X:
~e:java.lang.UnsatisfiedLinkError: dlopen failed: /data/app/myworldapp.people.com-1/lib/arm/liblame.so: has text relocations
~e:    at java.lang.Runtime.loadLibrary(Runtime.java:372)
~e:    at java.lang.System.loadLibrary(System.java:1076)
~e:    at net.sourceforge.lame.Lame.<clinit>(Lame.java:36)
~e:    at com.intervigil.lame.Encoder.initialize(Encoder.java:52)
~e:    at uk.co.martinpearman.b4a.liblame.EncoderWrapper.SetFiles(EncoderWrapper.java:92)
 

moster67

Expert
Licensed User
This is similar to what happens to ffmpeg.
In this moment I believe you must target SDK 22 or lower.
 
Upvote 0

moster67

Expert
Licensed User
If you need encoder-functionality, you could use my ffmpeg-encoder wrapper and as long as you target ARM (and not x86), it should work also with SDK 23. However, the ffmpeg-encoder wrapper is a big library so it might not be what you want. If you are interested, contact me in PM.
There might be alternatives though...Can you explain better what you use the liblame for?
 
Upvote 0
Top