iOS Question Local Mac Build Issue (v1.5)

Discussion in 'iOS Questions' started by samykabu, Mar 14, 2015.

  1. samykabu

    samykabu New Member Licensed User

    I have installed the B4 Bridge on a MAC with IP (192.168.10.35)
    The test page (http://192.168.10.35:51041/test) is working and everything as it should be.
    Connecting the IDE to the server works like a charm, code can be compiled with no issues.
    The problem is when I navigate to the URL(http://192.168.10.35:51041/) I see the install button but nothing happens , I tried removing the server folder and reinstalling it but the same issue happens again , also I repeated the process on another mac and the issue persisted.
    I have compared it with my hosted build account (which is working) and I have found that the browser generate an error about the URL (Unterminated string constant at
    location.href='itms-services://?action=download-manifest&url=https://192.168.10.35
    :51042/download?type%3Dmanifest_samy'
    )
    And it seems that the URL has a CR after the ip.
    I tried installing the bridge using iTunes manually, and it did install but once I start deploying the app it complains that it cannot connect to the server (192.168.10.35)
    Can you please help me fix it.
    Regards
    Samy K Abushanab


    Build Server Test Dump
    B4i Build Server
    Build server is running.
    Version: 1.5
    Server time: 20:03:30
    Mac SSL Key
    Key IP: 192.168.10.35
    SSL port: 51042
    h files
    • iAd: 1.00
    • iAdMob: 1.10
    • iArchiver: 1.01
    • iBarcode: 1.03
    • iBLE: 1.11
    • iCore: 1.78
    • iDebug: 1.60
    • iDesigner: 1.20
    • iDropboxSync: 1.00
    • iEncryption: 1.02
    • iGoogleMaps: 1.00
    • iHttp: 1.01
    • iHUD: 1.00
    • iJSON: 1.0
    • iLeadbolt: 1.00
    • iLocation: 1.00
    • iMedia: 1.20
    • iNet: 1.20
    • iNetwork: 1.10
    • iPhone: 1.30
    • iRandomAccessFile: 1.20
    • iSideMenu: 1.00
    • iSQL: 1.01
    • iStore: 1.0
    • iStringUtils: 1.00
    • iWebSocket: 1.00
    • iXmlBuilder: 1.00
    • iXmlSax: 1.00
    a files
    • libCore, size=2206664, modified=01/18/2015 15:26:40
    • libiAd, size=25928, modified=01/19/2015 17:29:26
    • libiAdMob, size=46464, modified=01/19/2015 16:36:16
    • libiArchiver, size=155824, modified=12/16/2014 00:21:18
    • libiBarcode, size=103200, modified=12/11/2014 16:12:00
    • libiBLE, size=83232, modified=01/21/2015 15:32:58
    • libiDebug, size=705024, modified=01/06/2015 00:05:50
    • libiDesigner, size=570768, modified=01/07/2015 23:06:50
    • libiDropboxSync, size=56408, modified=11/17/2014 17:07:32
    • libiEncryption, size=46664, modified=01/06/2015 19:33:32
    • libiGoogleMaps, size=107240, modified=10/30/2014 22:42:54
    • libiHttp, size=84712, modified=01/07/2015 16:56:56
    • libiHUD, size=192376, modified=10/30/2014 22:44:26
    • libiJSON, size=36576, modified=10/30/2014 22:44:56
    • libiLeadbolt, size=7744, modified=12/01/2014 21:35:54
    • libiLocation, size=50384, modified=11/16/2014 15:44:00
    • libiMedia, size=174752, modified=01/11/2015 19:53:52
    • libiNet, size=363344, modified=01/13/2015 23:29:32
    • libiNetwork, size=179168, modified=12/15/2014 18:16:38
    • libiPhone, size=153512, modified=01/12/2015 23:59:34
    • libiRandomAccessFile, size=249928, modified=12/17/2014 00:21:22
    • libiSideMenu, size=338504, modified=10/30/2014 22:50:00
    • libiSQL, size=243848, modified=12/23/2014 22:47:28
    • libiStore, size=35528, modified=01/21/2015 01:01:02
    • libiStringUtils, size=38168, modified=10/30/2014 22:50:50
    • libiWebSocket, size=265616, modified=01/06/2015 16:49:40
    • libiXmlBuilder, size=103920, modified=12/28/2014 23:46:22
    • libiXmlSax, size=42528, modified=10/30/2014 22:51:04
     
  2. samykabu

    samykabu New Member Licensed User

    BY the way this only happen when I set the IP manually in the key.txt
     
  3. Erel

    Erel Administrator Staff Member Licensed User

    Make sure that there is no extra space or new line character in the key.txt file.
     
  4. samykabu

    samykabu New Member Licensed User

    I edited the file in sublime and it is working now thanks
     
    Erel likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice